Bug 1009888 - unexpanded macros in scripts
unexpanded macros in scripts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: keepalived (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ryan O'Hara
Fedora Extras Quality Assurance
Ryan O'Hara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 08:31 EDT by David Juran
Modified: 2013-09-29 20:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: keepalived-1.2.8-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 21:23:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2013-09-19 08:31:08 EDT
Description of problem:
[djuran@localhost ~]$ rpm -q --scripts keepalived
postinstall scriptlet (using /bin/sh):
%systemd_post keepalived.service
preuninstall scriptlet (using /bin/sh):
%systemd_preun keepalived.service
postuninstall scriptlet (using /bin/sh):
%systemd_postun_with_restart keepalived.service



Version-Release number of selected component (if applicable):
keepalived-1.2.8-1.fc19
Comment 1 Ryan O'Hara 2013-09-19 11:37:48 EDT
Looks like I forgot the BuildRequires: systemd in the spec file. I also changed Requires(post,preun,postun) to systemd. Thanks for catching this bug.
Comment 2 Ryan O'Hara 2013-09-19 11:38:43 EDT
With fix:

$ rpm -q --scripts keepalived
postinstall scriptlet (using /bin/sh):

if [ $1 -eq 1 ] ; then 
        # Initial installation 
        /usr/bin/systemctl preset keepalived.service >/dev/null 2>&1 || : 
fi
preuninstall scriptlet (using /bin/sh):

if [ $1 -eq 0 ] ; then 
        # Package removal, not upgrade 
        /usr/bin/systemctl --no-reload disable keepalived.service > /dev/null 2>&1 || : 
        /usr/bin/systemctl stop keepalived.service > /dev/null 2>&1 || : 
fi
postuninstall scriptlet (using /bin/sh):

/usr/bin/systemctl daemon-reload >/dev/null 2>&1 || : 
if [ $1 -ge 1 ] ; then 
        # Package upgrade, not uninstall 
        /usr/bin/systemctl try-restart keepalived.service >/dev/null 2>&1 || : 
fi
Comment 3 Fedora Update System 2013-09-19 11:53:17 EDT
keepalived-1.2.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/keepalived-1.2.8-2.fc19
Comment 4 Fedora Update System 2013-09-19 16:05:53 EDT
keepalived-1.2.8-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/keepalived-1.2.8-2.fc20
Comment 5 David Juran 2013-09-20 07:22:19 EDT
Problem with the fix is that the %preuninstall of the old package fails so if you run "yum update", you'll end up with both the new and the old version. On the other hand, I'm not sure how to fix this in a good way either )-:
Comment 6 Fedora Update System 2013-09-20 12:20:41 EDT
Package keepalived-1.2.8-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing keepalived-1.2.8-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17193/keepalived-1.2.8-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-28 21:23:00 EDT
keepalived-1.2.8-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-09-29 20:33:16 EDT
keepalived-1.2.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.