Bug 1009897 - Adding zFCP device fails on s390x guest with one CPU
Summary: Adding zFCP device fails on s390x guest with one CPU
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils
Version: 6.5
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dan Horák
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks: 972747
TreeView+ depends on / blocked
 
Reported: 2013-09-19 12:54 UTC by Jan Stodola
Modified: 2014-10-14 07:35 UTC (History)
6 users (show)

Fixed In Version: s390utils-1.8.2-52.el6
Doc Type: Bug Fix
Doc Text:
Cause: incorrect order of initialization for zFCP disks Consequence: presence of zFCP disk not detected by Anaconda Fix: use cio_settle kernel interface to wait for the zFCP device to come online. Result: Anaconda sees the zFCp devices.
Clone Of:
Environment:
Last Closed: 2014-10-14 07:35:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1546 normal SHIPPED_LIVE s390utils bug fix and enhancement update 2014-10-14 01:21:28 UTC

Description Jan Stodola 2013-09-19 12:54:19 UTC
Description of problem:
On a z/VM guest with one CPU, anaconda fails to add a zFCP LUN for the first time user tries it. Following attempt using the same device_number/WWPN/LUN is successful. 

Version-Release number of selected component (if applicable):
anaconda-13.21.195-1.el6 (RHEL-6.4 GA)
anaconda-13.21.206-1.el6

How reproducible:
* always on a guest with one CPU and no DASDs (6 attempts)
* sometimes on a guest with one CPU and 3 DASDs
* seen twice on a system with two CPUs, hard to reproduce

Steps to Reproduce:
1. start vnc installation on an guest with one CPU
2. proceed to Specialized Storage Devices screen
3. go to Add Advanced Target - Add ZFCP LUN
4. enter device number, WWPN and LUN and click Add
5. see error message:
zFCP device 0.0.a007 not found, not even in device ignore list.
6. click OK and try to add the same device again - it will succeed.

Actual results:
zFCP device is not added, user has to repeat adding of the device

Expected results:
zFCP device is added successfully

Comment 5 Jan Stodola 2013-09-19 13:03:56 UTC
Code from storage/zfcp.py:
...
        if not os.path.exists(online):
            log.info("Freeing zFCP device %s" % (self.devnum,))
            iutil.execWithRedirect("zfcp_cio_free", ["-d", self.devnum],
                                   stdout="/dev/tty5", stderr="/dev/tty5")

        if not os.path.exists(online):
            raise ValueError, _(
                "zFCP device %s not found, not even in device ignore list."
                %(self.devnum,))
...

Reproduced manually:
[anaconda root@rtt7 root]# zfcp_cio_free -d a107; ls /sys/bus/ccw/drivers/zfcp/; sleep 1; ls /sys/bus/ccw/drivers/zfcp/
ls: cannot access /sys/bus/ccw/drivers/zfcp/: No such file or directory
0.0.a107  bind  module  uevent  unbind
[anaconda root@rtt7 root]#

I'm not sure if this is problem in anaconda/s390-utils/kernel, please reassign if necessary.

Comment 6 RHEL Program Management 2013-10-14 02:04:36 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 Samantha N. Bueno 2014-03-17 20:08:34 UTC
I don't believe anaconda is the correct component for this; the issue seems to be at a lower level than the installer. My assumption would be s390utils; reassigning.

Comment 9 Dan Horák 2014-03-18 07:58:33 UTC
Jan, I guess it's the same issue as in 1054691.

Comment 10 Jan Stodola 2014-03-18 08:17:18 UTC
Yes, it looks so.

Comment 12 Jan Stodola 2014-08-12 11:56:59 UTC
Not able to reproduce any more with s390utils-1.8.2-54.el6 on a system with one CPU:

[root@rtt7 ~]# cat /proc/cpuinfo 
vendor_id       : IBM/S390
# processors    : 1
bogomips per cpu: 2913.00
features        : esan3 zarch stfle msa ldisp eimm dfp etf3eh highgprs 
processor 0: version = FF,  identification = 11C047,  machine = 2827
[root@rtt7 ~]#
[root@rtt7 ~]# rpm -q s390utils
s390utils-1.8.2-54.el6.s390x
[root@rtt7 ~]#
[root@rtt7 ~]# zfcp_cio_free -d a107; ls /sys/bus/ccw/drivers/zfcp/; sleep 1; ls /sys/bus/ccw/drivers/zfcp/
0.0.a107  bind  module  uevent  unbind
0.0.a107  bind  module  uevent  unbind
[root@rtt7 ~]#

Also adding zFCP disk during installation works fine.
Not moving to VERIFIED in case you want to run additional tests.

Comment 13 Branislav Blaškovič 2014-09-02 08:40:14 UTC
Switching to VERIFIED as jstodola already verified this.

Comment 14 errata-xmlrpc 2014-10-14 07:35:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1546.html


Note You need to log in before you can comment on or make changes to this bug.