Bug 1009899 - exportDbSchema scripts generates output file with wrong name
exportDbSchema scripts generates output file with wrong name
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
low Severity low
: ---
: 3.3.2
Assigned To: Eli Mesika
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 09:08 EDT by Sandro Bonazzola
Modified: 2013-12-19 09:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:24:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19679 None None None Never

  None (edit)
Description Sandro Bonazzola 2013-09-19 09:08:51 EDT
Description of problem:
exportDbSchema scripts generates output file with wrong name

Version-Release number of selected component (if applicable):
ovirt-engine-dbscripts-3.4.0-0.2.master.20130918140615.git54da2f7.fc18.noarch

How reproducible:
100%

Steps to Reproduce:
1. /usr/share/ovirt-engine/dbscripts/exportDbSchema.sh -s localhost -d engine -u engine -v -l /tmp/log

Actual results:
-v doesn't trigger any verbosity and the ouptut is:
 Done.
 Exported file is .engine.select version from schema_version where current;
 03030890.schema.

The file created is:
"/usr/share/ovirt-engine/dbscripts/.engine.select version from schema_version where current;\n03030890.schema"


Expected results:
-v turn on verbosity or doesn't exist

 The output file created should be:
./usr/share/ovirt-engine/dbscripts/.engine.03030890.schema
Comment 1 Sandro Bonazzola 2013-09-19 09:28:32 EDT
(In reply to Sandro Bonazzola from comment #0)

> Actual results:
> -v doesn't trigger any verbosity and the ouptut is:
>  Done.
>  Exported file is .engine.select version from schema_version where current;
>  03030890.schema.
> 
> The file created is:
> "/usr/share/ovirt-engine/dbscripts/.engine.select version from
> schema_version where current;\n03030890.schema"

After further testing the wrong file naming is due to -v switch.


> Expected results:

-v turn on verbosity without causing wrong file naming

The output file created should be:
./usr/share/ovirt-engine/dbscripts/.engine.03030890.schema
Comment 2 Sandro Bonazzola 2013-11-06 11:02:34 EST
Moving target release to 3.3.2 since it's not fixed in 3.3.1 and not considered blocking.
Comment 3 Sandro Bonazzola 2013-12-13 11:02:12 EST
rc build done, moving to ON_QA, packages will be available on updates-testing repository.
Comment 4 Sandro Bonazzola 2013-12-19 09:24:50 EST
oVirt 3.3.2 has been released resolving the problem described in this bug report.

Note You need to log in before you can comment on or make changes to this bug.