Bug 1009919 - perl-5.18: Regexp::Grammars does not work due to bug in perl
perl-5.18: Regexp::Grammars does not work due to bug in perl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
http://www.nntp.perl.org/group/perl.p...
:
Depends On:
Blocks: 992666
  Show dependency treegraph
 
Reported: 2013-09-19 09:39 EDT by Petr Pisar
Modified: 2015-02-15 22:26 EST (History)
11 users (show)

See Also:
Fixed In Version: perl-Regexp-Grammars-1.039-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-15 22:26:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-09-19 09:39:50 EDT
Regexp::Grammars module and dependent modules do not work with perl-5.18 (https://rt.cpan.org/Public/Bug/Display.html?id=87880, bug #992666).

It was being solved for a long time <https://rt.perl.org/rt3//Public/Bug/Display.html?id=116823>, and it seems to have been solved int the blead <http://www.nntp.perl.org/group/perl.perl5.porters/2013/07/msg204660.html>, <http://www.nntp.perl.org/group/perl.perl5.porters/2013/08/msg206163.html>.

Perl 5.18 (F≥20) is affected, e.g perl-5.18.1-288.fc21.x86_64.
Comment 1 Petr Pisar 2013-09-19 10:26:28 EDT
There is nothing interesting in maint-5.18 (f4b15169f09b515c4765903d629c5125f9070e4a) after v5.18.1. However the discussion highlights two commits worth of back-porting:

<http://www.nntp.perl.org/group/perl.perl5.porters/2013/08/msg205655.html>:

commit c3923c33af542d8764d5a1e4eb5d7b311f443b89
Author:     David Mitchell <davem@iabyn.com>
AuthorDate: Tue Aug 6 16:34:50 2013 +0100
Commit:     David Mitchell <davem@iabyn.com>
CommitDate: Tue Aug 6 16:44:12 2013 +0100

    reparse compile-time /(?{})/ in right scope

<http://www.nntp.perl.org/group/perl.perl5.porters/2013/07/msg205393.html>:

commit c30fc27b4df65a43710b25dd1d2a57d78ee2fe33
Author: David Mitchell <davem@iabyn.com>
Date:   Wed Jul 31 22:41:17 2013 +0100

    Handle /[#]/ and /[(?#]/ with code blocks
Comment 2 Petr Pisar 2013-09-19 10:47:02 EDT
This:

commit c30fc27b4df65a43710b25dd1d2a57d78ee2fe33
Author: David Mitchell <davem@iabyn.com>
Date:   Wed Jul 31 22:41:17 2013 +0100

    Handle /[#]/ and /[(?#]/ with code blocks

has been already in 5.18.1.
Comment 3 Petr Pisar 2013-09-19 10:54:31 EDT
The `reparse compile-time /(?{})/ in right scope' patch does not seem to be enough.
Comment 4 Miro Hrončok 2013-10-16 10:02:39 EDT
Is there anything I can do about this? I'm not good at fixing Perl bugs, but people are filing bugs against slic3r and that bothers me.
Comment 5 Petr Pisar 2013-10-16 10:21:04 EDT
(In reply to Miro Hrončok from comment #4)
> Is there anything I can do about this? I'm not good at fixing Perl bugs, but
> people are filing bugs against slic3r and that bothers me.

Not much. You can troll on upstream list and ask when they are going to release fixed version (or at least fix it the development tree because I'm not aware of any fix).
Comment 6 Miro Hrončok 2013-10-18 19:54:30 EDT
I was SO wrong and slic3r now builds and works. This issue is still present, but it is no longer a priority for me.
Comment 7 Bill Pemberton 2015-02-06 12:02:29 EST
I just took a look at this again and it appears that perl-Regexp-Grammars will work with perl 5.18.4.  If I remove if test that has the module croak with the "perl 5.18 is unsupported" message, it will pass all the tests.  Also a couple of programs I have locally appear to work fine.

I've asked the author of the module if he knows of anything else that will prevent this module working on 5.18.4.  Assuming he doesn't know of anything, I can upgrade perl-Regexp-Grammars in F21 to version 1.038 to match rawhide.
Comment 8 Fedora Update System 2015-02-06 22:35:59 EST
perl-Regexp-Grammars-1.039-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-Regexp-Grammars-1.039-1.fc21
Comment 9 Fedora Update System 2015-02-08 03:58:53 EST
Package perl-Regexp-Grammars-1.039-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Regexp-Grammars-1.039-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1869/perl-Regexp-Grammars-1.039-1.fc21
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-02-15 22:26:49 EST
perl-Regexp-Grammars-1.039-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.