Bug 1009926 - Generating applicability causes traceback in pulp.log
Generating applicability causes traceback in pulp.log
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks: sat6-pulp-future
  Show dependency treegraph
 
Reported: 2013-09-19 09:51 EDT by Justin Sherrill
Modified: 2017-07-26 15:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:29:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-09-19 09:51:25 EDT
Description of problem:

Generating applicability for a set of consumers results in a large traceback in pulp.log:



2013-09-19 09:21:53,544 pulp.server.dispatch.call:ERROR: Exception encountered while pickling: call
2013-09-19 09:21:53,544 pulp.server.dispatch.call:ERROR: Can't pickle <function regenerate_applicability_for_consumers at 0x7fc1668d6ed8>: it's not found as pulp.server.managers.consumer.applicability.regenerate_applicability_for_consumers
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/dispatch/call.py", line 210, in serialize
    data[field] = pickle.dumps(getattr(self, field))
  File "/usr/lib64/python2.6/pickle.py", line 1366, in dumps
    Pickler(file, protocol).dump(obj)
  File "/usr/lib64/python2.6/pickle.py", line 224, in dump
    self.save(obj)
  File "/usr/lib64/python2.6/pickle.py", line 286, in save
    f(self, obj) # Call unbound method with explicit self
  File "/usr/lib64/python2.6/pickle.py", line 748, in save_global
    (obj, module, name))
PicklingError: Can't pickle <function regenerate_applicability_for_consumers at 0x7fc1668d6ed8>: it's not found as pulp.server.managers.consumer.applicability.regenerate_applicability_for_consumers
2013-09-19 09:21:53,596 pulp.server.dispatch.task:INFO: SUCCESS: Task 96f364ee-7de0-4e37-b850-d50756f20423: CallRequest: regenerate_applicability_for_consumers({'sort': None, 'skip': None, 'limit': None, 'filters': {'id': {'$in': ['integration_test_consumer']}}, 'fields': ['id'], '_id': ObjectId('523afa715ca0134fd30cf555'), 'id': '523afa715ca0134fd30cf555'})


The generation task seems to be successful (although i haven't yet checked the actual applicability data), but the error seems to always be generated


Version-Release number of selected component (if applicable):
pulp-server-2.3.0-0.12.alpha.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.  Use the applicability api to generate applicability data: https://pulp-dev-guide.readthedocs.org/en/latest/integration/rest-api/consumer/applicability.html
2.  Check /var/log/pulp/pulp.log


Actual results:
Nasty Traceback


Expected results:
No Traceback
Comment 1 Barnaby Court 2013-10-01 14:22:12 EDT
PR: https://github.com/pulp/pulp/pull/645
Comment 2 Jeff Ortel 2013-10-02 09:30:47 EDT
build: 2.3.0-0.17.beta
Comment 3 Preethi Thomas 2013-10-09 08:28:07 EDT
verified
[root@pulp-v2-server ~]# rpm -qa |grep pulp-server
pulp-server-2.3.0-0.17.beta.el6.noarch

Ran the  test_applicability_generation.py from playpen

No errors in pulp.log
Comment 4 Preethi Thomas 2013-12-09 09:29:54 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.