Bug 1009954 - Broken dependency for graphite-web-0.9.12-1.el5
Broken dependency for graphite-web-0.9.12-1.el5
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: graphite-web (Show other bugs)
el5
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 10:56 EDT by Matt Summers
Modified: 2014-03-07 18:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 19:04:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Summers 2013-09-19 10:56:15 EDT
Description of problem:
Trying to install the latest graphite-web has a broken dependency for Django-1.3

Version-Release number of selected component (if applicable):
0.9.12-1.el5

How reproducible:
Every time

Steps to Reproduce:
1. yum install graphite-web

Actual results:
Resolving Dependencies
--> Running transaction check
---> Package graphite-web.noarch 0:0.9.12-1.el5 set to be updated
--> Processing Dependency: Django >= 1.3 for package: graphite-web
--> Processing Dependency: pytz for package: graphite-web
--> Processing Dependency: python-whisper for package: graphite-web
--> Processing Dependency: pyparsing for package: graphite-web
--> Processing Dependency: mod_wsgi for package: graphite-web
--> Processing Dependency: dejavu-serif-fonts for package: graphite-web
--> Processing Dependency: dejavu-sans-fonts for package: graphite-web
--> Running transaction check
---> Package dejavu-sans-fonts.noarch 0:2.33-4.el5 set to be updated
--> Processing Dependency: dejavu-fonts-common = 2.33-4.el5 for package: dejavu-sans-fonts
---> Package dejavu-serif-fonts.noarch 0:2.33-4.el5 set to be updated
---> Package graphite-web.noarch 0:0.9.12-1.el5 set to be updated
--> Processing Dependency: Django >= 1.3 for package: graphite-web
---> Package mod_wsgi.x86_64 0:3.2-2.el5 set to be updated
---> Package pyparsing.noarch 0:1.5.0-3.el5 set to be updated
---> Package python-whisper.noarch 0:0.9.12-1.el5 set to be updated
---> Package pytz.noarch 0:2010h-1.el5 set to be updated
--> Running transaction check
---> Package dejavu-fonts-common.noarch 0:2.33-4.el5 set to be updated
--> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common
---> Package graphite-web.noarch 0:0.9.12-1.el5 set to be updated
--> Processing Dependency: Django >= 1.3 for package: graphite-web
--> Running transaction check
---> Package fontpackages-filesystem.noarch 0:1.44-1.el5.1 set to be updated
---> Package graphite-web.noarch 0:0.9.12-1.el5 set to be updated
--> Processing Dependency: Django >= 1.3 for package: graphite-web
--> Finished Dependency Resolution
graphite-web-0.9.12-1.el5.noarch from epel has depsolving problems
  --> Missing Dependency: Django >= 1.3 is needed by package graphite-web-0.9.12-1.el5.noarch (epel)
Error: Missing Dependency: Django >= 1.3 is needed by package graphite-web-0.9.12-1.el5.noarch (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Expected results:
Should resolve dependencies

Additional info:
from avij in irc
"graphite-web.noarch 0:0.9.12-2.el5 is in epel-testing, but sadly it appears to suffer from the same problem as the graphite-web.noarch 0:0.9.12-1.el5 in stable"
Comment 1 Anssi Johansson 2013-09-19 11:12:03 EDT
In addition to Django >= 1.3, graphite-web seems to depend on django-tagging. django-tagging does not seem to be available in EL5 or EPEL5.
Comment 2 Jonathan Steffan 2013-09-19 19:30:48 EDT
Thanks for the report. I can confirm this issue and am investigating the work needed to add Django14 to EPEL5. However, this is still a valid issue and I will be pushing out a 0.9.10 update with the CVE patched that will still run on Django 1.1.
Comment 3 Fedora Update System 2013-09-19 20:28:52 EDT
graphite-web-0.9.10-9.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/graphite-web-0.9.10-9.el5
Comment 4 Fedora Update System 2013-09-19 21:42:23 EDT
graphite-web-0.9.10-10.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/graphite-web-0.9.10-10.el5
Comment 5 Jonathan Steffan 2013-09-19 21:46:40 EDT
graphite-web-0.9.10-10.el5 should be a valid update now with the patch for CVE-2013-5093 applied.

An update to 0.9.12 is blocked until we get python26-sphinx10 in EPEL5 so we can build Django14 in EPEL5. The addition of django-tagging is now in progress.
Comment 6 Fedora Update System 2013-09-20 15:59:22 EDT
Package graphite-web-0.9.10-10.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing graphite-web-0.9.10-10.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11641/graphite-web-0.9.10-10.el5
then log in and leave karma (feedback).
Comment 7 Anssi Johansson 2013-09-21 14:03:01 EDT
Error: Missing Dependency: django-tagging is needed by package 1:graphite-web-0.9.10-10.el5.noarch (epel-testing)
Error: Missing Dependency: Django is needed by package 1:graphite-web-0.9.10-10.el5.noarch (epel-testing)

The absence of django-tagging was already mentioned in comment 5, but what about Django?
Comment 8 Matt Summers 2013-09-25 06:43:41 EDT
As mentioned in comment 7, there seems to still be a missing dependency for django-tagging. I already had this package before it was pulled so I can satisfy dependencies on this box, but a fresh install would not be able to.
Comment 9 Jonathan Steffan 2013-09-25 12:58:56 EDT
As it stands right now, the EPEL5 package is not working as desired and there are missing dependencies. I am going to work on getting releng to revoke the package if possible until I can get the correct dependencies in EPEL5.

https://fedorahosted.org/rel-eng/ticket/5780
Comment 10 Jonathan Steffan 2013-09-26 19:04:23 EDT
This package has been untagged from stable and I will continue to work on getting graphite-web into EPEL5 but there are many dependencies that need to be coordinated and reviewed.

This work will be completed in the epel-testing repo. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.