Bug 1009972 - [RFE] Utility to control file limits per user basis
[RFE] Utility to control file limits per user basis
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: jofernan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 11:42 EDT by dchia
Modified: 2016-04-13 14:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 14:41:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dchia 2013-09-19 11:42:08 EDT
Description of problem: Currently, there is existing script/utility to control storage per user basis. The admin runs "oo-admin-ctl-user -l $USER --setmaxtrackedstorage $GB" once for each user.

Customer would like to have similar feature to control file limits.

Additional info:
It will be nice to have if we also extend the utility features to include controls of CPU, memory, or processes limits for a particular user.
Comment 2 nicholas_schuetz 2014-09-22 14:17:09 EDT
Has this feature been addressed in OSE 2.x?
Comment 3 Brenton Leanhardt 2014-10-16 16:39:07 EDT
The number of files per gear is still only handled by the setting in /etc/openshift/resource_limits.conf.  That means it's still Node-wide which tends to mean it will need to be the same for all Nodes in that profile.

That said, we understand this sort of flexibility is desired and as such are building much greater flexibility in to the 3.x codebase.  In 3.x the inode limits won't really be needed simply because each container will have their own and won't share with the host system.  However, limits like memory, cpu, etc will indeed be controllable per user.

Note You need to log in before you can comment on or make changes to this bug.