Bug 1009979 - scribus-to-double patch breaks shape insertion tool
scribus-to-double patch breaks shape insertion tool
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 11:56 EDT by andreas.vox
Modified: 2014-08-27 11:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: scribus-1.4.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 21:30:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andreas.vox 2013-09-19 11:56:58 EDT
Description of problem:


Users cannot choose other shapes than rectangles when inserting a new shape.


How reproducible: ALWAYS


Steps to Reproduce:
1. select menu Insert -> Shape -> Special -> Tux

Actual results:
nothing or a rectangle is inserted

Expected results:
the drawing of a penguin is inserted

Additional info:

After reviewing your scribus-to-double patch I think the problem is that
the patch changes the signature of SelShape() to (int, int, double) but doesn't
adjust the connect method in the constructor of ModToolBar:

	connect(Rechteck, SIGNAL(FormSel(int, int, qreal *)), this, SLOT(SelShape(int, int, qreal *)));


should be:

	connect(Rechteck, SIGNAL(FormSel(int, int, qreal *)), this, SLOT(SelShape(int, int, double *)));


original report:
http://bugs.scribus.net/view.php?id=11738
Comment 1 Fedora Update System 2013-09-20 02:20:53 EDT
scribus-1.4.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/scribus-1.4.3-2.fc18
Comment 2 Fedora Update System 2013-09-20 02:21:02 EDT
scribus-1.4.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scribus-1.4.3-2.fc19
Comment 3 Fedora Update System 2013-09-20 02:21:11 EDT
scribus-1.4.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scribus-1.4.3-2.fc20
Comment 4 Fedora Update System 2013-09-20 14:54:58 EDT
Package scribus-1.4.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scribus-1.4.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17232/scribus-1.4.3-2.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-28 21:30:32 EDT
scribus-1.4.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-09-28 21:40:53 EDT
scribus-1.4.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-09-28 21:41:45 EDT
scribus-1.4.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Amich26 2014-03-11 07:53:58 EDT
In 1.4.3-2.fc20, the problem persist.
Comment 9 Mario Ceresa 2014-08-27 11:09:07 EDT
Confirmed it still happens. It seems to be due to[1]:

QObject::connect : Incompatible sender/receiver arguments
        AutoformButtonGroup::FormSel(int,int,qreal*) --> ModeToolBar::SelShape(int,int,double*)

I changed the slots with the patch[2] and it works for me. Not sure if there is something else still lingering on...

The new source rpm is available here[3] and the koji build is here[4]. 

HTH,

Mario

[1] http://bugs.scribus.net/view.php?id=11738
[2] https://www.dropbox.com/s/15qlefyq4ysz776/scribus-1.4.3-to-double-fixed.patch?dl=0
[3] https://www.dropbox.com/s/tf7hbl4rgax09il/scribus-1.4.3-3.fc20.src.rpm?dl=0
[4] http://koji.fedoraproject.org/koji/taskinfo?taskID=7467066

Note You need to log in before you can comment on or make changes to this bug.