Bug 1010005 - pip-python3 installs to /usr/ (instead of /usr/local)
pip-python3 installs to /usr/ (instead of /usr/local)
Status: CLOSED DUPLICATE of bug 662034
Product: Fedora
Classification: Fedora
Component: python-pip (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Flink
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 12:53 EDT by Matěj Cepl
Modified: 2013-10-15 10:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 10:58:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2013-09-19 12:53:08 EDT
Description of problem:
wycliff:~# pip-python3 install ipdb
Downloading/unpacking ipdb
  Downloading ipdb-0.8.zip
  Running setup.py egg_info for package ipdb
    
Requirement already satisfied (use --upgrade to upgrade): ipython>=0.10 in /usr/lib/python3.3/site-packages (from ipdb)
Installing collected packages: ipdb
  Running setup.py install for ipdb
    
    Fixing build/lib/ipdb/__init__.py build/lib/ipdb/__main__.py
    Skipping implicit fixer: buffer
    Skipping implicit fixer: idioms
    Skipping implicit fixer: set_literal
    Skipping implicit fixer: ws_comma
    Fixing build/lib/ipdb/__init__.py build/lib/ipdb/__main__.py
    Skipping implicit fixer: buffer
    Skipping implicit fixer: idioms
    Skipping implicit fixer: set_literal
    Skipping implicit fixer: ws_comma
    Installing ipdb3 script to /usr/bin
Successfully installed ipdb
Cleaning up...
wycliff:~# ls /usr/bin/ipdb3
/usr/bin/ipdb3
wycliff:~# ls /usr/local/bin/ipdb3
ls: cannot access /usr/local/bin/ipdb3: No such file or directory
wycliff:~# ls -d /usr/lib/python3.3/site-packages/ipd*
/usr/lib/python3.3/site-packages/ipdb
/usr/lib/python3.3/site-packages/ipdb-0.8-py3.3.egg-info
wycliff:~#

Version-Release number of selected component (if applicable):
python3-pip-1.1-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.

Actual results:
Everything is installed to directories directly under /usr/ (/usr/lib/python*, /usr/bin) etc.

Expected results:
To this directory only rpm should write, everything else should go to /usr/local
Comment 1 Felix Schwarz 2013-10-07 04:58:45 EDT
I think the current behavior is fine because /usr/local/... is not part of the default python path on Fedora (IIRC!). Also easy_install always installed to /usr/lib.

pip has a command line flag to install to another location or you can resort to virtualenvs.
Comment 2 Tim Flink 2013-10-15 10:58:20 EDT
If python and python3 are not looking in /usr/local for packages, there is little point in having pip install there.

As mentioned in c#1, virtualenvs or alternate locations on the command line are options

*** This bug has been marked as a duplicate of bug 662034 ***

Note You need to log in before you can comment on or make changes to this bug.