Bug 101002 - RHN using older contact information of Org. Admin in email notification
RHN using older contact information of Org. Admin in email notification
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
high Severity high
: ---
: ---
Assigned To: Chip Turner
Red Hat Satellite QA List
:
Depends On:
Blocks: 99024
  Show dependency treegraph
 
Reported: 2003-07-28 10:18 EDT by Lars Herrmann
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 09:51:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Herrmann 2003-07-28 10:18:55 EDT
Problem is: RHN using old contact information of Org. Admin in email notification

For RHN account rhndemo@redhat.de was registered Manfred Hollstein as Org.
Admin. Then I took over the account changing all contact info to Lars Herrmann.
All relevant forms were updated.

After adding a new user to this account (rhndemo_jkune@redhat.de) I received the
following mail:

<mail>

Subject: RHN User Created: rhndemo_jkunze@redhat.de (Kunze, Joachim
<jkunze+rhndemo@redhat.de>)

Hello, 

A new user has been added to Manfred Hollstein.


Account Information:
  Your RHN login:         rhndemo_jkunze@redhat.de
  Your RHN email address: jkunze+rhndemo@redhat.de

Visit the User List to view them:

  https://rhn.redhat.com/network/users/index.pxt

Thank you for using Red Hat Network.
--the Red Hat Network Team

</mail>

The notification should not mention any older contact information including
names IMHO.
Comment 1 Greg DeKoenigsberg 2003-07-30 09:53:40 EDT
We need to check this out.  If we can replicate, we need to fix it.

Lars, are you sure that you went through the "confirm change" step when you
changed contact info -- i.e. you received an email to the old address and
confirmed the change there?

Comment 2 Chip Turner 2003-07-30 10:05:38 EDT
the issue is the original creator of the org.  Since this string isn't editable
and almost never displayed, I've changed the text of the email in CVS HEAD.
Comment 3 Greg DeKoenigsberg 2003-08-13 17:48:14 EDT
DOCS: None, it's a bugfix.

TEST PLAN:  Create a new account with one email address.  Give user enterprise
slots so that he has multi-user.  Change this first org_admin's email address
and various info.  Create a new account; an email will be sent to the new
org_admin email address.  Make sure that this email contains no uniquely
identifiable information about the original org_admin.
Comment 4 Josef Komenda 2003-08-14 14:33:39 EDT
Looks good in dev.
Comment 5 Josef Komenda 2003-08-21 18:14:17 EDT
Looks good in webqa. 
Comment 6 Josef Komenda 2003-08-26 09:51:59 EDT
Looks good in prod. 

Note You need to log in before you can comment on or make changes to this bug.