Bug 1010027 - We need to index, handle errors, and generate metadata for repos that have content uploaded via UI
We need to index, handle errors, and generate metadata for repos that have co...
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
: Triaged
Depends On:
Blocks: 1010023
  Show dependency treegraph
 
Reported: 2013-09-19 14:16 EDT by David Davis
Modified: 2013-10-17 16:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 16:15:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Davis 2013-09-19 14:16:30 EDT
The upload content method on repository doesn't update the indices for packages/puppet modules, return errors, or call generate_metadata.
Comment 1 RHEL Product and Program Management 2013-09-19 14:25:55 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 David Davis 2013-09-19 15:14:39 EDT
https://github.com/Katello/katello/pull/3004
Comment 4 David Davis 2013-09-20 12:00:41 EDT
Katello SHA a5bf6258910031b51c4021f9c884d938c7f56ca2

Content Uploads: Adding indexing and error checking

Note You need to log in before you can comment on or make changes to this bug.