Bug 1010042 - signo: logging out from foreman does not fully logout of UI, can login as previous user for katello UI
signo: logging out from foreman does not fully logout of UI, can login as pre...
Status: CLOSED DUPLICATE of bug 969886
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 14:57 EDT by Corey Welton
Modified: 2014-01-16 16:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:26:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-09-19 14:57:40 EDT
Description of problem:
When signed in as user in katello, switching to foreman, logging out and logging in as new user, returning to katello will remain logged in as the first user.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Login as admin user to /katello 
2. Create new user, "fibble"
3. Navigate to Provisioning
4. Logout admin user
5. Login as fibble
6. Navigate to Content; view name of logged in user

Actual results:
Logged in user is still admin

Expected results:
Logging out from UI should logout across all portions of unified UI
User should not be able to exist as previously logged-in user in other portions of UI.


Additional info:
I think this is a regression?  I'm fairly (though not 100%) sure this worked before.
Comment 1 Corey Welton 2013-09-19 14:59:38 EDT
Similarly, logging out of katello ui and then clicking provisioning button will result in being logged in as previous user as well.
Comment 3 Marek Hulan 2013-09-26 03:00:02 EDT
I think this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=969886

The question is, do we want some bigger changes to Katello and Signo to support this even when Signo won't be used in future? There's still a quick and dirty way to achieve logout - we could just delete user session cookies but since Katello uses cookie store session there may be data that we should not delete.

So can't we just say that this is a known "feature" of current version which will be changed later?
Comment 4 Corey Welton 2013-10-09 10:26:35 EDT
QA Closing.

*** This bug has been marked as a duplicate of bug 969886 ***
Comment 5 Mike McCune 2014-01-16 16:16:47 EST
removing signo component and moving these bugs to 'Infrastructure'

Note You need to log in before you can comment on or make changes to this bug.