Bug 1010056 - [abrt] libvirt-client-1.1.2-1.fc19: __assert_fail_base: Process /usr/bin/virsh was killed by signal 6 (SIGABRT)
[abrt] libvirt-client-1.1.2-1.fc19: __assert_fail_base: Process /usr/bin/virs...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:25cb6f558dd439b94d9ee61aab4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 15:57 EDT by Eric Blake
Modified: 2013-09-23 15:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 15:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.90 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: cgroup (141 bytes, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: core_backtrace (5.59 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: dso_list (5.82 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: environ (3.32 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: maps (28.04 KB, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: open_fds (268 bytes, text/plain)
2013-09-19 15:57 EDT, Eric Blake
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-09-19 15:58 EDT, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2013-09-19 15:57:08 EDT
Description of problem:
Bug reported on libvirt list, latent until 1.1.2 release turned it into an abort():
https://www.redhat.com/archives/libvir-list/2013-September/msg01143.html

Already patched on master and v1.1.2-maint:
commit fe64499dd14315b2d9d62cdf421bd3c97a46b7ac
Author: Simone Gotti <simone.gotti@gmail.com>
Date:   Thu Sep 19 15:08:29 2013 +0200

    virsh: add missing "async" option in opts_block_commit
    
    After commit 8aecd351266a66efa59b7f7be77bf66693d99ce0 it'll detect
    that a required option is not defined and it will assert and exit with:
    
    virsh.c:1364: vshCommandOpt: Assertion `valid->name' failed.
    
    Problem has been latent since commit ed23b106.
    
    Signed-off-by: Eric Blake <eblake@redhat.com>

Version-Release number of selected component:
libvirt-client-1.1.2-1.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        virsh -c test:///default blockcommit test a --wait
crash_function: __assert_fail_base
executable:     /usr/bin/virsh
kernel:         3.10.7-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            14986
var_log_messages: Sep 19 13:53:48 red abrt[4807]: Saved core dump of pid 4804 (/usr/bin/virsh) to /var/tmp/abrt/ccpp-2013-09-19-13:53:47-4804 (11567104 bytes)

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 __assert_fail_base at assert.c:92
 #3 __assert_fail at assert.c:101
 #4 vshCommandOpt at virsh.c:1365
 #5 vshCommandOptBool at virsh.c:1633
 #6 cmdBlockCommit at virsh-domain.c:1583
 #7 vshCommandRun at virsh.c:1722
Comment 1 Eric Blake 2013-09-19 15:57:16 EDT
Created attachment 800121 [details]
File: backtrace
Comment 2 Eric Blake 2013-09-19 15:57:21 EDT
Created attachment 800122 [details]
File: cgroup
Comment 3 Eric Blake 2013-09-19 15:57:28 EDT
Created attachment 800123 [details]
File: core_backtrace
Comment 4 Eric Blake 2013-09-19 15:57:34 EDT
Created attachment 800124 [details]
File: dso_list
Comment 5 Eric Blake 2013-09-19 15:57:39 EDT
Created attachment 800125 [details]
File: environ
Comment 6 Eric Blake 2013-09-19 15:57:45 EDT
Created attachment 800126 [details]
File: limits
Comment 7 Eric Blake 2013-09-19 15:57:50 EDT
Created attachment 800127 [details]
File: maps
Comment 8 Eric Blake 2013-09-19 15:57:56 EDT
Created attachment 800128 [details]
File: open_fds
Comment 9 Eric Blake 2013-09-19 15:58:02 EDT
Created attachment 800129 [details]
File: proc_pid_status
Comment 10 Eric Blake 2013-09-19 15:58:19 EDT
Fedora 20 and rawhide are impacted (also Fedora 19 if using fedora-virt-preview)
Comment 11 Cole Robinson 2013-09-23 15:08:46 EDT
Fixed in libvirt-1.1.2-3.fc21

Note You need to log in before you can comment on or make changes to this bug.