Bug 1010057 - `perldoc perldoc`: No documentation found for "perldoc".
`perldoc perldoc`: No documentation found for "perldoc".
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Pod-Perldoc (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 16:15 EDT by Vadim Raskhozhev
Modified: 2013-11-10 01:16 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-Pod-Perldoc-3.20-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1015993 (view as bug list)
Environment:
Last Closed: 2013-11-10 01:16:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 88898 None None None Never

  None (edit)
Description Vadim Raskhozhev 2013-09-19 16:15:41 EDT
Description of problem:
Command
perldoc perldoc
exits with
No documentation found for "perldoc".

Version-Release number of selected component (if applicable): perl-Pod-Perldoc-3.19.01-1.fc19.noarch

How reproducible: always

Steps to Reproduce:
1. yum install perl-Pod-Perldoc-3.19.01-1.fc19.noarch
2. perldoc perl # Shows what it should
3. perldoc perldoc

Actual results:
No documentation found for "perldoc".

Expected results:
Contents of perldoc.pod
Comment 1 Petr Pisar 2013-09-23 03:23:18 EDT
You can use `perldoc Pod::perldoc'. This is upstream change since version 3.17. I raised a question if this is intended behaviour <https://rt.cpan.org/Public/Bug/Display.html?id=88898>.
Comment 2 Petr Pisar 2013-09-23 04:11:01 EDT
And of course the classic `man perldoc' works.
Comment 3 Vadim Raskhozhev 2013-09-23 06:04:01 EDT
> I raised a question if this is intended behaviour <https://rt.cpan.org/Public/Bug/Display.html?id=88898>.

Thanks. IMHO if this is intended then the line 'Also try "perldoc perldoc" to get acquainted with the system.' in output of `perldoc' should somehow point to `perldoc Pod::perldoc', `man perldoc' or so.
Comment 4 Gerd Pokorra 2013-10-04 06:31:04 EDT
I configured the current stable perl source (5.18.1) with:

./configure.gnu --prefix=/home/blabla/install

and installed it (make install).

The following works:

For command output:

/home/blabla/install/bin/perldoc perldoc

For Perl5 module output:

/home/blabla/install/bin/perldoc Pod::Perldoc



This doesn't work:
/home/blabla/install/bin/perldoc Pod::Perldoc
No documentation found for "Pod::perldoc".


documentation as a Perl Utility
perldoc: http://perldoc.perl.org/index-utilities.html <-> http://perldoc.perl.org/perldoc.html


documentation as a Perl Module
Pod::Perldoc: http://search.cpan.org/~mallen/Pod-Perldoc-3.20/lib/Pod/Perldoc.pm
Comment 5 Gerd Pokorra 2013-10-04 06:33:13 EDT
Sorry:

This doesn't work:
/home/blabla/install/bin/perldoc Pod::perldoc
No documentation found for "Pod::perldoc".
Comment 6 Petr Pisar 2013-10-07 04:34:07 EDT
Upstream is not responsive. I will fix this issue by moving perldoc.pod to the root of Perl search path to make restore the `perldoc perldoc' command.

F≥19 are affected.
Comment 7 Fedora Update System 2013-10-07 05:06:25 EDT
perl-Pod-Perldoc-3.20-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Pod-Perldoc-3.20-7.fc20
Comment 8 Fedora Update System 2013-10-07 05:09:09 EDT
perl-Pod-Perldoc-3.19.01-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Pod-Perldoc-3.19.01-2.fc19
Comment 9 Fedora Update System 2013-10-07 11:45:23 EDT
Package perl-Pod-Perldoc-3.20-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Pod-Perldoc-3.20-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18464/perl-Pod-Perldoc-3.20-7.fc20
then log in and leave karma (feedback).
Comment 10 Vadim Raskhozhev 2013-10-08 11:36:02 EDT
(In reply to Petr Pisar from comment #6)
> Upstream is not responsive. I will fix this issue by moving perldoc.pod to
> the root of Perl search path to make restore the `perldoc perldoc' command.
> 
> F≥19 are affected.

Thanks, with 3.19.01-2 perldoc perldoc works as expected. Should I close the bug now?
Comment 11 Petr Pisar 2013-10-09 02:05:02 EDT
Thank you for testing. This bug report gets closed automatically once the updated packages become into stable repository. There is not action needed from you.
Comment 12 Fedora Update System 2013-10-18 15:36:19 EDT
perl-Pod-Perldoc-3.19.01-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-11-10 01:16:59 EST
perl-Pod-Perldoc-3.20-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.