Bug 1010068 - [RFE] Add --wait switch to cause glusterd to stay in the foreground until child services are started
Summary: [RFE] Add --wait switch to cause glusterd to stay in the foreground until chi...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-19 20:53 UTC by Joe Julian
Modified: 2018-11-19 04:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 04:48:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joe Julian 2013-09-19 20:53:04 UTC
When deploying using automation tools, follow-up steps will fail as they follow too closely to glusterd daemonizing. This causes automated deployments to take multiple runs to create a GlusterFS cluster.

If we can add the ability to have daemonizing wait until everything is active and running this would solve this problem.

Comment 1 purpleidea 2013-09-19 21:01:47 UTC
Thanks Joe. here's the relevant commit and hack that I use to get around this :P
I don't mind though.

https://github.com/purpleidea/puppet-gluster/commit/17aff1a33a001cbb56735ff9f61a9bbcaa40cb04

Cheers

James

Comment 2 Louis Zuckerman 2014-08-06 20:32:07 UTC
Upstart, and probably systemd & other event driven init systems, would benefit from this, in cases where a client mounts from localhost during boot.  The service started event should not fire until the service is really ready to serve requests.  Currently if mounts are tried immediately after the service starts they will fail, because it's not really ready when it daemonizes.

Thanks.

Comment 3 Vijay Bellur 2018-11-19 04:48:47 UTC
Migrated to github:

https://github.com/gluster/glusterfs/issues/550

Please follow the github issue for further updates on this bug report.


Note You need to log in before you can comment on or make changes to this bug.