Bug 101008 - public beta does not include DAC960 driver - RHEL2.1 did
Summary: public beta does not include DAC960 driver - RHEL2.1 did
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-28 14:54 UTC by Lars Herrmann
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 15:59:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv and uname -r on affected machine (within anaconda) (8.22 KB, text/plain)
2003-07-29 11:37 UTC, Patrick C. F. Ernzer
no flags Details

Description Lars Herrmann 2003-07-28 14:54:53 UTC
Install on FSC Siemens L200/P200 with Mylex Raid Controllers fails, because
kernel-BOOT does not recognize the controller. No module DAC960 included and
also pcitable does not include any DAC reference.

Comment 1 Patrick C. F. Ernzer 2003-07-29 11:37:16 UTC
Created attachment 93220 [details]
lspci -vvv and uname -r on affected machine (within anaconda)

Comment 5 Patrick C. F. Ernzer 2003-07-30 08:55:10 UTC
additional note: examination of the kernel-source RPM shows that the dac960 module was moved 
to unsupported.

Two questions:
  - can we get it back into supported (we're willing to test here of course)?
  - should CD1/images not include an image with unsupported modules?

RU

PCFE

Comment 6 Tim Burke 2003-07-30 12:21:40 UTC
Currently, the impediment to getting the megaraid driver onto the supported list
is the fact that development does not have any such hardware.  If we had at
least 1 to test with (within a week or 2) then we could probably get it added
back onto the supported list.  

Any efforts to secure an adapter would be appreciated.

Comment 8 Patrick C. F. Ernzer 2003-07-30 16:09:56 UTC
Tim,

I guess you meant to say dac960 and not megaraid.

A few things we can do:
  - we bug FSC for such a controller (from what I head we have pretty good chances for this)
  - we get FSC to run the tests
  - we run tests here (I'm on-site until Friday and willing to run all necessary tests)
  - generating driver disks for the unsupported modules

Lars, please comment on the chances of getting Tim such a controller within a week or 2.

Comment 10 Tim Burke 2003-08-11 13:15:54 UTC
Please ship to:


Red Hat
Attn: Tom Coughlan
3 Lan Dr.
Westford, MA 01886


Comment 13 Jay Turner 2003-08-19 15:59:31 UTC
Fix confirmed:

[haring (jkt):/mnt/redhat/test/Taroon-re0818.B2.0/i386/i386/RedHat/RPMS]$ rpm
-qpl kernel*.rpm | egrep "drivers/block/DAC960.o"
/lib/modules/2.4.21-1.1931.2.393.ent/kernel/drivers/block/DAC960.o
/lib/modules/2.4.21-1.1931.2.393.ent/kernel/drivers/block/DAC960.o
/lib/modules/2.4.21-1.1931.2.393.entBOOT/kernel/drivers/block/DAC960.o
/lib/modules/2.4.21-1.1931.2.393.enthugemem/kernel/drivers/block/DAC960.o
/lib/modules/2.4.21-1.1931.2.393.entsmp/kernel/drivers/block/DAC960.o
/lib/modules/2.4.21-1.1931.2.393.entsmp/kernel/drivers/block/DAC960.o



Note You need to log in before you can comment on or make changes to this bug.