Bug 101009 - Deprecate SiteNode/PackageType/PackageInstance classes
Summary: Deprecate SiteNode/PackageType/PackageInstance classes
Status: CLOSED DUPLICATE of bug 98408
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-28 15:04 UTC by Daniel Berrange
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2003-07-28 15:04:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
As discussed previously, now that the Application & ApplicationType classes are
documented & fully functional, the SiteNode / PackageType / PackageInstance
classes need to be marked as deprecated for the Troika release. Without this we
will have to live with the complexity / inconsistency of SiteNodes for yet
another release cycle before we can remove the code.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile an app using SiteNodes

    

Actual Results:  No warnings

Expected Results:  Deprecation warnings are emitted.

Additional info:

Comment 1 Richard Li 2003-07-28 15:10:20 UTC

*** This bug has been marked as a duplicate of 98408 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:57:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.