Bug 1010122 - [ALL_LANG][Admin Portal][User Portal] VM tab -> Snapshots subtab -> string "Active VM" is unlocalized
[ALL_LANG][Admin Portal][User Portal] VM tab -> Snapshots subtab -> string "...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
low Severity low
: ---
: 3.3.0
Assigned To: Tomas Jelinek
Yuko Katabami
virt
: CodeChange, i18n
Depends On:
Blocks: 3.3snap2 1046718
  Show dependency treegraph
 
Reported: 2013-09-20 00:15 EDT by Yuko Katabami
Modified: 2014-01-21 17:20 EST (History)
10 users (show)

See Also:
Fixed In Version: is22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1046718 (view as bug list)
Environment:
Last Closed: 2014-01-21 17:12:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Active VM" is not localized (283.51 KB, image/png)
2013-09-20 00:15 EDT, Yuko Katabami
no flags Details
Not fixed Active VM (29.51 KB, image/png)
2013-12-02 04:34 EST, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19542 None None None Never
oVirt gerrit 20767 None None None Never

  None (edit)
Description Yuko Katabami 2013-09-20 00:15:42 EDT
Created attachment 800272 [details]
"Active VM" is not localized

Description of problem:
String "Active VM" is not localized in Snapshots subtab under VM tab.

Version-Release number of selected component (if applicable): 3.3.0-0.22


How reproducible: 100%


Steps to Reproduce:
1. Login to Admin Portal in any given localized locale
2. Click Virtual Machines tab
3. Select a VM from the list
4. Click Snapshots subtab
5. Check the string in Description column


Actual results:
Active VM is shown in English

Expected results:
It should be localized

Additional info:
Screenshot is attached
Comment 1 Einav Cohen 2013-09-20 11:51:56 EDT
"Active VM" is originating from the backend. I guess that we can decide that for snapshots with "SnapshotType.ACTIVE", we will not display the snapshot-description that arrived from the backend, and instead display a localized "Active VM" string (that we will keep in CommonApplicationConstants or similar).
Comment 2 Yuko Katabami 2013-09-23 00:22:28 EDT
This bug is also found in User Portal.
Comment 3 Tomas Jelinek 2013-09-23 11:01:44 EDT
The problem is that the server stores this data into the DB in an unlocalized way (SnapshotsManager.addActiveSnapshot)
A similar situation is in the TryBackToAllSnapshotsOfVmCommand.executeVmCommand where we hardcode the "Active VM before the preview" string. 

It is basically a result of a dirty approach to show the more verbose SnapshotType on FE inside a description column instead of having a specific column for it.

Now, there are two possible approaches how to solve this:
1: quick and equally dirty - localize the description on FE for some specific 
   statuses
2: correct: enrich the snapshots subtab under VM tab by the "Type" column which 
   would contain the localized SnapshotType (REGULAR, ACTIVE, STATELESS, PREVIEW) 
   and remove the hardcoded descriptions (the user would be still able to provide 
   custom descritions)

It is not too much of work with the second but changes that table a bit (adds a column)

@Michal - thoughts?
Comment 4 Michal Skrivanek 2013-09-23 11:08:07 EDT
2) is fine
Comment 5 Lijun Li 2013-12-02 04:32:00 EST
Verified it's NOT FIXED on latest is25 build.
'Active VM' still not localized.

Please see the attached screenshot.
Comment 6 Lijun Li 2013-12-02 04:34:04 EST
Created attachment 831480 [details]
Not fixed Active VM
Comment 7 Tomas Jelinek 2013-12-04 02:30:22 EST
the localized keys are:
snapshotDescriptionActiveVm
snapshotDescriptionActiveVmBeforePreview

which are in the: frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationConstants.java

but in no localized version of the file (CommonApplicationConstants_*_*.properties)

@Einav: 
Hi,
could you please advise how to proceed and also how to avoid this situation in the future?
Thank you
Comment 9 Einav Cohen 2013-12-26 13:31:12 EST
(In reply to Tomas Jelinek from comment #7)
> @Einav: 
> Hi,
> could you please advise how to proceed and also how to avoid this situation
> in the future?
> Thank you

Hi Tomas, I apologize for the late response. 

Unfortunately, we cannot avoid these situations in the future: Your patch has been merged to master/ovirt-engine-3.3 on Oct 31/Nov 4 (see [1]), long time after the last translation cycle for 3.3 / 3.3 string freeze (see [2]). 
So the English strings went into the code, but no one translated them. 

Actually, this issue should have been divided to two BZs: One that tracks the code change (virt), and one that tracks the translation (i18n). 

This BZ already tracks your code-change, therefore I am changing the Whiteboard to be 'virt', adding the 'Code-Change' Keyword (as the fix alone cannot be verified), re-flagging it for 3.3 and moving it to VERIFIED (as this is a 'Code-Change' that was merged and part of the last few 3.3 builds).

The originally-reported issue should be verified by the i18n QE team in the context of the cloned Bug 1046718 (will happen only in 3.4). 

[1] http://gerrit.ovirt.org/#/q/I26866fd4dd91d034e7ae5afee054080a4ab864a1,n,z

[2] https://post-office.corp.redhat.com/mailman/private/rhev-devel/2013-August/msg00153.html
Comment 10 Itamar Heim 2014-01-21 17:12:50 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:20:55 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.