Bug 1010153 - glusterd: If a server is already part of another cluster and User tries to add it using command 'gluster peer probe <hostname/ip>' ; It is failing but not giving reason for failure
glusterd: If a server is already part of another cluster and User tries to ad...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
:
Depends On: 1004699 1237022 1252448
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 01:52 EDT by Krutika Dhananjay
Modified: 2016-03-21 06:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1004699
Environment:
Last Closed: 2014-04-17 07:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-20 02:10:28 EDT
REVIEW: http://review.gluster.org/5978 (glusterd: Set op_errstr appropriately on peer op failure) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Krutika Dhananjay 2013-09-20 02:11:11 EDT
Posted for review in upstream ---> http://review.gluster.org/#/c/5978/
Comment 3 Anand Avati 2013-09-24 01:38:34 EDT
REVIEW: http://review.gluster.org/5978 (glusterd: Set op_errstr appropriately on peer op failure) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Anand Avati 2013-09-27 01:32:03 EDT
REVIEW: http://review.gluster.org/5978 (glusterd: Set errstr appropriately on peer op failure) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Anand Avati 2013-09-29 20:02:42 EDT
COMMIT: http://review.gluster.org/5978 committed in master by Anand Avati (avati@redhat.com) 
------
commit f84c710e93ab48dceabd3824f5286ed3edd9b60d
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Fri Sep 20 11:37:51 2013 +0530

    glusterd: Set errstr appropriately on peer op failure
    
    Change-Id: I27f5f7cd54115d7b236b42f6beaaa05a8b379dd7
    BUG: 1010153
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/5978
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2014-04-17 07:48:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.