Bug 1010165 - Problem with Berkeley DB use in PAM_ABL
Problem with Berkeley DB use in PAM_ABL
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pam_abl (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 02:39 EDT by Petr Tuma
Modified: 2013-09-22 13:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 13:13:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Tuma 2013-09-20 02:39:16 EDT
Description of problem:

In some situations, the system login procedure (logging in through console or remote shell) displays Berkeley DB error messages coming from PAM_ABL. The messages include:

pam-abl: BDB1528 DB_REGISTER limits processes to one open DB_ENV handle per environment

(This one is usually displayed after first login fails and second is attempted.)

pam-abl: BDB2506 file /var/lib/abl/hosts.db has LSN 87/6343932, past end of log at 87/6332752
pam-abl: BDB2507 Commonly caused by moving a database from one database environment
pam-abl: BDB2508 to another without clearing the database LSNs, or by removing all of
pam-abl: BDB2509 the log files from a database environment
pam-abl: BDB1579 Database handles still open at environment close

(This one appeared today but I could not find a systematic way of triggering it.)

Version-Release number of selected component (if applicable):

pam_abl-0.5.0-2

How reproducible:

Some of the messages, always.

Steps to Reproduce:
1. Install PAM_ABL into PAM.
2. Switch to text console login prompt.
3. Attempt one incorrect login (non existent user does the trick just fine).
4. On second login attempt, just after entering the user name, the Berkeley DB error message will appear.

Actual results:

Error message where there should be none.

Expected results:

No error displayed.

Additional info:

I've also experimented with deleting and recreating the database to make sure this is not due to transient database corruption.

I'm not sure if the error messages hurt anything, but I've experienced unreliable login through GDM (login rejected and user blacklisted after a single failure, or login rejected even when user was not apparently blacklisted and could log in through console), could be this is somehow related.
Comment 1 Petr Tuma 2013-09-22 13:13:13 EDT
In the meantime, I have moved to pam_abl-0.6.0-2.fc20 (which has other issues fixed), and I don't see the error messages anymore. I will reopen the issue in case they appear again.

Thanks, Petr

Note You need to log in before you can comment on or make changes to this bug.