Bug 1010170 - ovs-vsctl: cannot create a port named gre-# because a port named gre-# already exists on bridge br-tun
ovs-vsctl: cannot create a port named gre-# because a port named gre-# alread...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 02:56 EDT by Sandro Mathys
Modified: 2016-04-26 10:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 04:16:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Neutron configs on Controller and Compute nodes, for reference. (8.12 KB, text/plain)
2013-12-09 04:14 EST, Kashyap Chamarthy
no flags Details

  None (edit)
Description Sandro Mathys 2013-09-20 02:56:15 EDT
Description of problem:
It seems the openvswitch-agent is trying to create ports on bridges that exist already. Obviously, it should better first check whether they exist already (or expect and handle the error).

Version-Release number of selected component (if applicable):
openstack-neutron-2013.2-0.4.b3.el6.noarch
openstack-neutron-openvswitch-2013.2-0.4.b3.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Set up OpenStack (Havana-3) with Neutron, OVS and GRE
2. Create a public network, tenant network and router in between
3. Launch an instance
4. Reboot the host / controller

Actual results:
# grep ERROR -A4 /var/log/neutron/openvswitch-agent.log
2013-09-20 08:35:49.097 2039 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'add-port', 'br-tun', 'gre-1']. Exception: 
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'add-port', 'br-tun', 'gre-1']
Exit code: 1
Stdout: ''
Stderr: 'ovs-vsctl: cannot create a port named gre-1 because a port named gre-1 already exists on bridge br-tun\n'
2013-09-20 08:35:54.383 2039 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'add-port', 'br-tun', u'gre-3']. Exception: 
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'add-port', 'br-tun', 'gre-3']
Exit code: 1
Stdout: ''
Stderr: 'ovs-vsctl: cannot create a port named gre-3 because a port named gre-3 already exists on bridge br-tun\n'

Expected results:
No errors :)

Additional info:
So it looks like this has no actual consequences. The port exists (already) and that's all that counts. Doesn't seem to try to rollback or exit or something because it hits an error. So it's probably more of a blemish.
Comment 1 Kashyap Chamarthy 2013-12-09 04:12:16 EST
Can you still reproduce this consistently?

I have a Havana 2-node setup with Neutron, OVS, GRE.

-----
$ rpm -qa | grep -i neutron
python-neutron-2013.2-3.fc21.noarch
python-neutronclient-2.3.1-2.fc20.noarch
openstack-neutron-2013.2-3.fc21.noarch
openstack-neutron-openvswitch-2013.2-3.fc21.noarch
-----

I've rebooted the Controller and Compute nodes many times, and I do not see the problem you've indicated.

---------------------
[root@ostack-controller ~(keystone_kashyap)]$ grep ERROR /var/log/neutron/openvswitch-agent.log | grep -i port
[root@ostack-controller ~(keystone_kashyap)]$
---------------------
[root@ostack-controller ~(keystone_kashyap)]$ ovs-vsctl show 
09745d56-d93a-4967-9d69-2b047cf61f66
    Bridge br-int
        Port "tap0e21a72b-01"
            tag: 2
            Interface "tap0e21a72b-01"
        Port "tapd48caa63-3c"
            tag: 2
            Interface "tapd48caa63-3c"
        Port "tapc67bb976-ce"
            tag: 1
            Interface "tapc67bb976-ce"
        Port br-int
            Interface br-int
                type: internal
        Port "tap229364da-e7"
            tag: 1
            Interface "tap229364da-e7"
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-tun
        Port "gre-2"
            Interface "gre-2"
                type: gre
                options: {in_key=flow, local_ip="192.169.142.118", out_key=flow, remote_ip="192.169.142.209"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    Bridge br-ex
        Port "tap4e064969-f7"
            Interface "tap4e064969-f7"
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    ovs_version: "2.0.0"
Comment 2 Kashyap Chamarthy 2013-12-09 04:14:27 EST
Created attachment 834236 [details]
Neutron configs on Controller and Compute nodes, for reference.
Comment 3 Sandro Mathys 2013-12-09 04:16:04 EST
I currently lack the resources to try a fresh setup but I don't see this error on a system is is running for a while already (and I think it should have shown with every reboot), so probably not, no.

Note You need to log in before you can comment on or make changes to this bug.