Bug 1010181 - Crash of Cadence Virtuoso when using remote connection
Crash of Cadence Virtuoso when using remote connection
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-desktop3 (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 03:23 EDT by R G
Modified: 2015-02-17 12:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 12:15:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error reported (538 bytes, text/plain)
2013-09-20 03:23 EDT, R G
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1004979 None None None Never

  None (edit)
Description R G 2013-09-20 03:23:03 EDT
Created attachment 800324 [details]
Error reported

Description of problem:
I run a program (Cadence IC6, which is closed source Qt-based) on a remote machine through SSH with X11 forwarding.

After updating my client machine from Ubuntu12 to Fedora19 64-bit, I get some errors when running the Cadence program. It worked also perfectly with fedora 18.

Version-Release number of selected component (if applicable):
Cedence: 6.1.5-64b.500.14
gnome-desktop3-3.8.4

How reproducible:
100% reproductible !
Note tha

Steps to Reproduce:
1. Connect to server with "ssh -X user@serveur"
2. Launch "virtuoso &"
3. Launch library manager

Actual results:
Nothing but error messages (see attachement)

Expected results:
Open windows !


Additional info:
Works with Ubuntu 12.04 LTS
Works with Fedora 18
Works with Fedora 19 and the MATE desktop !

I am not specialist, so please ask me anything that may help to solve that bug !
Comment 1 Mallikarjun 2013-10-14 10:12:12 EDT
This bug is present only in fedora 19 and later versions. In fedora 18, this bug is not there. SSH process to cadence server works fine in fedora 18. Please give me some inputs on how to solve this problem.

Here is how we can reproduce the problem-

1. Successful in opening the cadence virtuoso from a remote cadence server in fedora 19.
2. Clicking on the open option and selecting the drop down menu button causes all other processes (including other applications like firefox if opened along with terminal and cadence) to hang and get stuck indefinitely.
3. The problem happens if we click on the drop down buttons in any other cadence windows also.

Please help me to solve this bug in Fedora 19.

Mallikarjun.
Comment 2 Mallikarjun 2013-10-14 10:14:22 EDT
This bug is prevalent if using Fedora 19 with GNOME desktop. Fedora 18 with GNOME desktop worked fine.
Comment 3 Mallikarjun 2013-10-15 09:29:55 EDT
Hi,

Has anyone been able to find any solutions to this bug. Waiting for inputs on how to solve this bug.

Mallikarjun
Comment 4 Mallikarjun 2013-10-21 04:53:36 EDT
Any updates?
Comment 5 Rui Matos 2013-10-21 05:09:16 EDT
(In reply to R G from comment #0)
> I run a program (Cadence IC6, which is closed source Qt-based)

Which version of Qt is this? Can you perhaps force it to load the F19 provided version of Qt?
Comment 6 R G 2013-10-21 08:15:04 EDT
Unfortunately, the server is a "production" computer and I am not allowed to to any modification in installation.
This server provides qt version 3.3.6 (25.el5)

I have tried on a virtual machine, with qt 4.6.2 (26.el6_4), and it seems to work perfectly !

My client has qt version 4.8.5 (10.fc19).

I do not know hiw to force Cadence to use another version of qt on the server side.

What I do not understand is that it works with Cinnamon and Mate (with qt 3.3.6 on the server side and 4.8.5 on the client side), but NOT with gnome on the client side (same qt version).
Comment 7 Mallikarjun 2013-10-23 00:08:34 EDT
Sir,

This problem is only in FC19 GNOME desktop, any changes that can be done in the GNOME desktop to solve this problem?

Mallikarjun
Comment 8 Mallikarjun 2013-10-25 15:28:51 EDT
Any updates?
Comment 9 Mallikarjun 2013-10-31 08:56:10 EDT
Hey guys, any ways to resolve this problem?
Comment 10 Mallikarjun 2013-11-04 10:18:12 EST
Hey, could you please fix this problem in the upcoming version of fedora i.e, fedora 20?
Comment 11 Fedora End Of Life 2015-01-09 14:54:23 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2015-02-17 12:15:45 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.