Bug 1010221 - Various filesystem errors on node install
Various filesystem errors on node install
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
x86_64 Linux
unspecified Severity high
: ---
: 3.4.1
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 05:58 EDT by Netbulae
Modified: 2014-04-23 02:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 02:58:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug information (136.75 KB, application/x-zip)
2013-09-20 06:02 EDT, Netbulae
no flags Details
screenshot partition layout (76.13 KB, image/png)
2013-12-02 08:19 EST, Netbulae
no flags Details
sceenshot error on boot (8.51 KB, image/png)
2013-12-02 08:20 EST, Netbulae
no flags Details

  None (edit)
Description Netbulae 2013-09-20 05:58:34 EDT
Description of problem:

I replaced the SSD of the first node with a brand new Samsung 256GB SSD and the second node with a 1TB HDD to be sure the problems aren't with the original SSD's.

When I change the SWAP size on both nodes to 4GB, it fails to install the bootloader:
"Exception: RuntimeError('Failed to set install bootloader'.)"

When I leave everything on default and just continue the steps, I get the following error on BOTH nodes:
"Exception: OSError(30, 'Read-only file system')"

When I choose Other drive and select /dev/sda, I get the following Exception:
"Exception: ValueError("invalid literal for int() with base 10: ' '",)"

So I'm kinda stuck :-&

Our RAID chip is LSI 2108 SAS


Version-Release number of selected component (if applicable):

ovirt-node-iso-3.0.1-1.0.2.vdsm.fc19.iso

How reproducible:

Every time

I attached debug info from all three steps as instructed.
Comment 1 Netbulae 2013-09-20 06:02:03 EDT
Created attachment 800394 [details]
debug information
Comment 2 Fabian Deutsch 2013-11-28 07:31:45 EST
Hey,

could you please check if the problem still exists with 3.0.3?
Comment 3 Netbulae 2013-11-29 10:36:42 EST
I deployed ovirt-node-iso-3.0.3-1.1.vdsm.fc19.iso today. The installer works fine now but after reboot I get this:

.
error: $.
error: syntax error.
error: Incorrect command.
error: syntax error.
alloc magic is broken at 0xbf747080: fce8d455
Aborted. Press any key to exit.

This is on a 1tb hdd.
Comment 4 Fabian Deutsch 2013-11-29 13:31:22 EST
Ugh.

Where di you see/get this?
Comment 5 Netbulae 2013-11-30 14:14:52 EST
I use an IPMI to see what's going on on the node. This is what I get on the screen after a reboot. When I press ENTER, I get some no boot device error.
Comment 6 Fabian Deutsch 2013-12-02 03:13:07 EST
That is weird.
Do you know from what part the "syntax error" comes from? IPMI, grub, ...?
Comment 7 Netbulae 2013-12-02 08:19:30 EST
Created attachment 831571 [details]
screenshot partition layout

Booted a LiveCD and I see the first partition is unknown.
Comment 8 Netbulae 2013-12-02 08:20:48 EST
Created attachment 831572 [details]
sceenshot error on boot
Comment 9 Netbulae 2013-12-02 08:43:17 EST
I also tested it on another node with the same error.
Comment 10 Sandro Bonazzola 2014-03-04 04:23:38 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 11 Netbulae 2014-03-31 07:26:33 EDT
This hasn't been a problem since the latest builds. 

So I think this can be closed.
Comment 12 haiyang,dong 2014-04-23 02:58:23 EDT
According to comment 11,  closed this bug

Note You need to log in before you can comment on or make changes to this bug.