Bug 1010223 - [RHSC] Show a dialog when rebalance is started on multiple volumes, some of which have rebalance in progress.
[RHSC] Show a dialog when rebalance is started on multiple volumes, some of w...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Nishanth Thomas
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 06:01 EDT by Shruti Sampat
Modified: 2015-08-28 06:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 06:43:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2013-09-20 06:01:47 EDT
Description of problem:
--------------------------
When multiple volumes are selected for performing rebalance and rebalance is started on them from the Console, if some of those volumes have rebalance already running on them, the Console needs to show a dialog which will tell the user that rebalance is running on some of the selected volumes, so it will be started on the rest of them.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.2.master.20130911113322.gite7ade4a.fc19 

How reproducible:
Always

Steps to Reproduce:
1. Select some volumes for performing rebalance, some of which have rebalance already running.

Actual results:
Rebalance menu is disabled.

Expected results:
Rebalance menu should be enabled, and on clicking on Start, a dialog should open telling the user that rebalance is running on some of these volumes and will be started on the rest of them.

Additional info:
Comment 2 Dusmant 2013-10-22 02:42:21 EDT
Severity was not specified -- So moved it to low Severity, considering it's not impacting the functionality, but rather an usability issue.

We (Shruti, Kanagaraj and Dusmant ) had a discussion on this and we decided to defer this usability fix to next release. The reason being there are other places in volumes table ( like Start ) where upon multiple selection, the Start or Stop menu is disabled, if one of the volumes has already started.

In the next release, we should address this as follows.
-------------------------------------------------------
If the user selects multiple rows in the volumes table, and on one or multiple of those selected rows rebalance is already running, then also "Rebalance" menu should be enabled ( Currently it gets disabled ). Upon pressing the Rebalance menu, a info dialogue should come up, which should read as follows...
"Rebalance is started on : <list-of-volume-names-where-rebalance-will-be-started> volume(s). Rebalance is already running on : <list-of-volumes-where-rebalance-is-already-running> volume(s)".  UI layer should pass-on a filtered list of selected volumes, on which rebalance is not already running. Info dialogue will be closed, when the "Ok" button is pressed.

Note that, this dialogue would NOT come for multiple selection, if rebalance is not running on any of the selected volumes 

Exception case is going to be : if someone started it on a volume from CLI and it has not synched-up yet on UI, then this dialogue will not come, but later a warning message will come saying "Failed to start rebalance on : <volume-list>, because it's already running. Started rebalance on : <rest-of-the-selected-volume-list>". But internally, engine should take care of starting Rebalance on the rest of the volumes-- This is going to be slightly tricky, but it has to work this way.

=============Exact similar steps should be done for Start Volume as well=======
Comment 3 Dusmant 2015-08-28 06:43:10 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.