Bug 1010270 - storage node installation fails if java exec is not set on PATH environment variable
storage node installation fails if java exec is not set on PATH environment v...
Status: CLOSED DUPLICATE of bug 1016609
Product: JBoss Operations Network
Classification: JBoss
Component: CLI (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: ER04
: JON 3.2.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 08:18 EDT by Jeeva Kandasamy
Modified: 2013-10-11 09:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 09:37:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install-storage-node-fails (2.25 KB, text/x-log)
2013-09-20 08:18 EDT, Jeeva Kandasamy
no flags Details

  None (edit)
Description Jeeva Kandasamy 2013-09-20 08:18:55 EDT
Created attachment 800475 [details]
install-storage-node-fails

Description of problem:
while installing JON, it's request to set 'RHQ_SERVER_JAVA_HOME', set it as 'export RHQ_SERVER_JAVA_HOME=/opt/applications/jdk1.7.0_40/', however cassandra storage node throws exception, 
-------------------------------------------
20:44:16,709 ERROR [org.rhq.storage.installer.StorageInstaller] The storage node reported the following errors while trying to start:

./cassandra: line 140: exec: java: not found
-------------------------------------------

if we set 'export PATH=$PATH:/opt/applications/jdk1.7.0_40/bin/', work as expected

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version: 3.2.0.ER1
Build Number: 54dd29c:464a643
GWT Version: 2.5.0
SmartGWT Version: 3.0

How reproducible:
100%

Steps to Reproduce:
1. do not set java exec location on environment PATH variable
2. ./rhqctl install

Actual results:
storage node installation fails

Expected results:
'java' exec should take it from 'RHQ_SERVER_JAVA_HOME' variable

Additional info: log is attached
Comment 1 Simeon Pinder 2013-10-08 03:52:44 EDT
Moving into ER04 as not completed in ER03.
Comment 2 Jay Shaughnessy 2013-10-11 09:37:58 EDT
I'm setting this as a duplicate of Bug 1016609. Even though it's not exactly the same the work on that BZ will cover this one as well.

*** This bug has been marked as a duplicate of bug 1016609 ***

Note You need to log in before you can comment on or make changes to this bug.