Bug 1010294 - [vdsm] Cannot attach export domain - Storage.HSM::(getStorageDomainsList) Unexpected error
[vdsm] Cannot attach export domain - Storage.HSM::(getStorageDomainsList) Une...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.2.4
Assigned To: Ayal Baron
Aharon Canan
storage
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 09:09 EDT by Jiri Belka
Modified: 2016-02-10 13:28 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 04:44:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (291.85 KB, text/x-log)
2013-09-20 09:09 EDT, Jiri Belka
no flags Details
engine.log (698.76 KB, application/x-gzip)
2013-09-23 11:05 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-09-20 09:09:46 EDT
Created attachment 800505 [details]
vdsm.log

Description of problem:
I cannot attach an export domain into 3.2 env, although the same domain can be attached without any problem to 3.3 env. It used to work in 3.2 domain?

Import storage domain dialog:

Use Host: dell-r210ii-04 (SPM)
Export Path: 10.34.63.202:/mnt/export/nfs/lv1/jbelka/export

There is no storage domain under the specified path. Check event log for more details.

... nothing in Events!

Thread-207616::ERROR::2013-09-20 14:31:14,390::hsm::2732::Storage.HSM::(getStorageDomainsList) Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/hsm.py", line 2718, in getStorageDomainsList
    if storageType and storageType != dom.getStorageType():
  File "/usr/share/vdsm/storage/sd.py", line 731, in getStorageType
    return self.getMetaParam(DMDK_TYPE)
  File "/usr/share/vdsm/storage/sd.py", line 728, in getMetaParam
    return self._metadata[key]
  File "/usr/share/vdsm/storage/persistentDict.py", line 89, in __getitem__
    return dec(self._dict[key])
  File "/usr/share/vdsm/storage/persistentDict.py", line 201, in __getitem__
    raise KeyError(key)
KeyError: 'TYPE'

... manual test ...

# /bin/mount -t nfs -o soft,nosharecache,timeo=600,retrans=6,nfsvers=3 10.34.63.202:/mnt/export/nfs/lv1/jbelka/export /mnt
[root@dell-r210ii-04 ~]# ls -l /mnt/
total 4
drwxr-xr-x. 5 vdsm kvm 4096 Jun  5 10:51 ca414eb9-98ab-422f-8c4e-c2c513231058
-rwxr-xr-x. 1 vdsm kvm    0 Jun 19 15:10 __DIRECT_IO_TEST__
[root@dell-r210ii-04 ~]# cat /mnt/ca414eb9-98ab-422f-8c4e-c2c513231058/dom_md/metadata 
CLASS=Backup
DESCRIPTION=str-01-jbelka-export
IOOPTIMEOUTSEC=1
LEASERETRIES=3
LEASETIMESEC=5
LOCKPOLICY=
LOCKRENEWALINTERVALSEC=5
MASTER_VERSION=0
POOL_UUID=
REMOTE_PATH=10.34.63.202:/mnt/export/nfs/lv1/jbelka
ROLE=Regular
SDUUID=ca414eb9-98ab-422f-8c4e-c2c513231058
TYPE=NFS
VERSION=0
_SHA_CKSUM=eee7363deca8da0a5de426e623334874f4ac0060

... /var/log/messages ...
Sep 20 14:31:16 dell-r210ii-04 kernel: device-mapper: table: 253:3: multipath: error getting device
Sep 20 14:31:16 dell-r210ii-04 kernel: device-mapper: ioctl: error adding target to table
Sep 20 14:31:16 dell-r210ii-04 kernel: device-mapper: table: 253:3: multipath: error getting device
Sep 20 14:31:16 dell-r210ii-04 kernel: device-mapper: ioctl: error adding target to table
-%--

Version-Release number of selected component (if applicable):
sf20.3

How reproducible:
?

Steps to Reproduce:
1. have an export domain
2. try to attach in 3.2 env
3.

Actual results:
There is no storage domain under the specified path. Check event log for more details.

Expected results:


Additional info:
if you cannot reproduce with clean export domain, ping me to get access to my export domain
Comment 1 Jiri Belka 2013-09-20 09:12:35 EDT
VDSM     => vdsm-4.10.2-25.1.el6ev.x86_64
libvirt  => libvirt-0.10.2-18.el6_4.10.x86_64
qemu     => qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64
Comment 3 Nir Soffer 2013-09-23 09:51:29 EDT
(In reply to Jiri Belka from comment #0)

> 
> How reproducible:
> ?

Did you try several times? did you get the same error in all tries?
Comment 4 Jiri Belka 2013-09-23 10:30:30 EDT
I tried many many times, a couple of times it resulted in 'registred' export domain in RHEVM but down, it was mounted but I could not find a way to put it up. But I did not find exact way how to reproduce it.
Comment 5 Nir Soffer 2013-09-23 10:41:26 EDT
So it always fails but with different errors, or it sometimes works and sometimes not?

Please attach also engine log while trying to attach the domain.
Comment 6 Jiri Belka 2013-09-23 11:05:14 EDT
Created attachment 801701 [details]
engine.log

there's no error in engine.log during this issue, but anyway, see attachment
Comment 7 Nir Soffer 2013-09-23 13:30:51 EDT
Again, does it always fail or sometimes fail?
Comment 8 Jiri Belka 2013-09-24 04:19:56 EDT
I cannot import thus the functionality fails for me. Usual issue is error in vdsm.log. For other issue I cannot provide reproduce steps. Please instead of chatting via NEEDINFO, ping me directly or I can give you access to my export domain.
Comment 9 Nir Soffer 2013-09-24 05:21:32 EDT
Assuming reproducible: always
Comment 10 Ayal Baron 2013-09-30 07:42:00 EDT
what DC level are you using in 3.2?
Sounds like you have a V3 export storage domain which can only be attached to newer DC levels (3.2 DC level iirc).
Comment 11 Jiri Belka 2013-09-30 09:49:55 EDT
I'm using 3.2 DC level.
Comment 12 Jiri Belka 2013-10-01 03:27:10 EDT
I just upgraded host to libvirt-0.10.2-18.el6_4.14 packages, reboot and voila, I can attach the export domain.
Comment 13 Allon Mureinik 2013-10-02 04:44:14 EDT
closing as per comment 12 .
Comment 14 Allon Mureinik 2013-10-02 04:44:32 EDT
closing as per comment 12 .

Note You need to log in before you can comment on or make changes to this bug.