Bug 1010311 - unable to boot F19 & F20 by UUID after clean install - device does not exist
unable to boot F19 & F20 by UUID after clean install - device does not exist
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 09:38 EDT by Mark Haney
Modified: 2014-01-22 09:29 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-22 09:29:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport.txt of the problem with booting by UUID on this device (74.81 KB, text/plain)
2013-09-20 09:39 EDT, Mark Haney
no flags Details

  None (edit)
Description Mark Haney 2013-09-20 09:38:20 EDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Build Identifier: 

Fresh install of F19 on a Samsung netbook that is dual boot and ran F16/17 just fine will not boot now by using UUID.  With F16 I could go into grub and change the boot/root partitions to /dev/sdaX and it would boot fine.  Now, with grub2 something has changed and I cannot force it to use the /dev/ designation to boot.  I get 'Reached Target Basic System' then it bombs with /dev/disk-by-UUID/<uuid of drive>/does not exist.  I am attaching the sosreport.txt below.

Even following the grub2 instructions from fedoraproject.org doesn't let me boot from a grub> prompt.  I get the same error.

Reproducible: Always

Steps to Reproduce:
1. Fresh install of F19
2. reboot after install 
.
Actual Results:  
After a bit it drops to Emergency mode dracut prompt with device does not exist error. 

Expected Results:  
Should boot properly.

I'll be glad to debug in any way that will help.
Comment 1 Mark Haney 2013-09-20 09:39:25 EDT
Created attachment 800509 [details]
sosreport.txt of the problem with booting by UUID on this device
Comment 2 Mark Haney 2013-12-17 12:16:11 EST
Updated bug to include Fedora 20.  Same problem. I'll help debug/troubleshoot in any way I can. I want to get this fixed.
Comment 3 Harald Hoyer 2014-01-22 05:30:35 EST
You have a problem with your drive.

[   32.736081] localhost kernel: ata1.00: exception Emask 0x0 SAct 0x1 SErr 0x0 action 0x6 frozen
[   32.736092] localhost kernel: ata1.00: failed command: READ FPDMA QUEUED
[   32.736101] localhost kernel: ata1.00: cmd 60/08:00:a8:01:00/00:00:00:00:00/40 tag 0 ncq 4096 in
         res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   32.736106] localhost kernel: ata1.00: status: { DRDY }
[   32.736111] localhost kernel: ata1: hard resetting link
[   33.196069] localhost kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   33.197299] localhost kernel: ata1.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[   33.197515] localhost kernel: ata1.00: ACPI cmd ef/10:01:00:00:00:a0 (SET FEATURES) succeeded
[   33.197723] localhost kernel: ata1.00: ACPI cmd ef/10:02:00:00:00:a0 (SET FEATURES) succeeded
[   33.197728] localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   33.197928] localhost kernel: ata1.00: ACPI cmd ef/10:04:00:00:00:a0 (SET FEATURES) succeeded
[   33.198136] localhost kernel: ata1.00: ACPI cmd ef/10:05:00:00:00:a0 (SET FEATURES) rejected by device (Stat=0x51 Err=0x04)
[   33.200565] localhost kernel: ata1.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[   33.200571] localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   33.200779] localhost kernel: ata1.00: ACPI cmd ef/10:05:00:00:00:a0 (SET FEATURES) rejected by device (Stat=0x51 Err=0x04)
[   33.201134] localhost kernel: ata1.00: configured for UDMA/133
[   33.201141] localhost kernel: ata1.00: device reported invalid CHS sector 0
[   33.201161] localhost kernel: ata1: EH complete
[   33.454604] localhost systemd-udevd[78]: worker [82] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda timeout; kill it
[   33.456491] localhost systemd-udevd[78]: seq 1030 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' killed
[   33.562340] localhost systemd-udevd[78]: worker [82] terminated by signal 9 (Killed)
[   63.591384] localhost systemd-udevd[78]: worker [81] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda1 timeout; kill it
[   63.591854] localhost systemd-udevd[78]: seq 1031 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda1' killed
[   63.593401] localhost systemd-udevd[78]: worker [83] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda2 timeout; kill it
[   63.593921] localhost systemd-udevd[78]: seq 1032 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda2' killed
[   63.598705] localhost systemd-udevd[78]: worker [84] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda3 timeout; kill it
[   63.600268] localhost systemd-udevd[78]: seq 1033 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda3' killed
[   63.600733] localhost systemd-udevd[78]: worker [87] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda4 timeout; kill it
[   63.602221] localhost systemd-udevd[78]: seq 1034 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda4' killed
[   63.602715] localhost systemd-udevd[78]: worker [88] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda5 timeout; kill it
[   63.604251] localhost systemd-udevd[78]: seq 1035 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda5' killed
[   63.604723] localhost systemd-udevd[78]: worker [89] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda6 timeout; kill it
[   63.606308] localhost systemd-udevd[78]: seq 1036 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda6' killed
[   63.606808] localhost systemd-udevd[78]: worker [90] /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda7 timeout; kill it
[   63.608326] localhost systemd-udevd[78]: seq 1037 '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda/sda7' killed
[   63.608781] localhost systemd-udevd[78]: worker [87] terminated by signal 9 (Killed)
[   63.611158] localhost systemd-udevd[78]: worker [88] terminated by signal 9 (Killed)
[   93.792076] localhost kernel: ata1.00: exception Emask 0x0 SAct 0x3 SErr 0x0 action 0x6 frozen
[   93.792085] localhost kernel: ata1.00: failed command: READ FPDMA QUEUED
[   93.792094] localhost kernel: ata1.00: cmd 60/08:00:68:b1:db/00:00:1c:00:00/40 tag 0 ncq 4096 in
         res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   93.792098] localhost kernel: ata1.00: status: { DRDY }
[   93.792102] localhost kernel: ata1.00: failed command: READ FPDMA QUEUED
[   93.792109] localhost kernel: ata1.00: cmd 60/08:08:80:07:80/00:00:01:00:00/40 tag 1 ncq 4096 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   93.792113] localhost kernel: ata1.00: status: { DRDY }
[   93.792119] localhost kernel: ata1: hard resetting link
Comment 4 Mark Haney 2014-01-22 09:29:21 EST
These messages have been showing up since I purchased the netbook and installed Fedora 16.  It's never been a problem until Fedora 18 was released and I upgraded to it.  At one point I had to edit the boot config to set root to use /dev/sdaX instead of the UUID to make it work, but work it did. Until F18.  And 19.  And now 20.  

I've run Windows 7 on this machine since it was purchased with no trouble and I just installed Sabayon linux and it works just fine.  Sabayon being built on a Gentoo base must mean something in the Fedora package for dracut just doesn't work on this machine.  

Regardless, the drive is not bad. However, if that's how it's going to be seen (and dealt with), fine.

Note You need to log in before you can comment on or make changes to this bug.