Bug 1010321 - Globally uncaught exception while trying to compare datasource's configuration
Globally uncaught exception while trying to compare datasource's configuration
Status: NEW
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 1010319
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 09:54 EDT by bkramer
Modified: 2013-09-20 09:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2013-09-20 09:54:59 EDT
Description of problem:
It is not possible to compare datasource's configurations. I tried some other resources and compare configuration worked fine.

Version-Release number of selected component (if applicable):
RHQ 4.4.0

How reproducible:
Always

Steps to Reproduce:
1. Navigate to DefaultDS resource (on the left side) -> Configuration -> Current
2. Make a change in the DefaultDS;
3. In the Configuration -> History -> select two configurations and press "Compare" button; 

Actual results:
The screen will be dimmed and "Globally Uncaught Exception" will be displayed in the background. The only way to go get rid of this dimmed screen is to refresh the page. At the same time there are no exceptions logged in the rhq-server-log4j.log file and no messages logged in the Message Center. 

Expected results:
To have pop-up window that would display differences between two configurations.

Additional info:
This was tested with EAP 5.1.2.

Note You need to log in before you can comment on or make changes to this bug.