Bug 1010324 - missing allow rule for symlinks labeled git_system_content_t
missing allow rule for symlinks labeled git_system_content_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 993793
  Show dependency treegraph
 
Reported: 2013-09-20 10:04 EDT by Milos Malik
Modified: 2013-11-21 05:52 EST (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-218.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1015603 (view as bug list)
Environment:
Last Closed: 2013-11-21 05:52:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-09-20 10:04:17 EDT
Description of problem:
Following rule, which was requested in bz#883143, is missing in current policy:
allow httpd_t git_system_content_t : lnk_file { getattr read }

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-216.el6.noarch
selinux-policy-targeted-3.7.19-216.el6.noarch

How reproducible:
always
Comment 1 Miroslav Grepl 2013-10-02 02:49:28 EDT
$ sesearch -A -s httpd_t -t git_system_content_t
Found 4 semantic av rules:
   allow httpd_t git_sys_content_t : file { ioctl read getattr lock open } ; 
   allow httpd_t git_sys_content_t : dir { ioctl read getattr lock search open } ; 
   allow httpd_t git_sys_content_t : lnk_file { read getattr } ; 
   allow httpd_t file_type : filesystem getattr ;
Comment 4 errata-xmlrpc 2013-11-21 05:52:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1598.html

Note You need to log in before you can comment on or make changes to this bug.