Bug 1010335 - user-data script fails to install httpd
user-data script fails to install httpd
Status: CLOSED DUPLICATE of bug 990910
Product: Fedora
Classification: Fedora
Component: cloud-init (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
: EC2
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 10:31 EDT by mkovacik
Modified: 2013-09-26 19:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 19:18:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer userdata cloud-init script (138 bytes, text/plain)
2013-09-20 10:31 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2013-09-20 10:31:15 EDT
Created attachment 800520 [details]
reproducer userdata cloud-init script

Description of problem:
userdata cloud-init script fails to install httpd because httpd scriptlets fail to execute. 
It seems some filesystem service might not be ready at the time user-data script is executed as the error codes suggest (127 file not found).

See the attachment for the user-data script; Additional info section gives a screen log of the situation.

Version-Release number of selected component (if applicable):
ami-f1031e85; Official Fedora AMI - Fedora-x86_64-19-20130627-sda

How reproducible:
always

Steps to Reproduce:
1. init the launch of ami-f1031e85 in ec2 (eu-west-1)
2. in instance details, give the attached script as user data script (load from filesystem)
3. launch the instance
4. log-in and cat /var/log/httpd_userdata.log

Actual results:
file-not-found scriptlet errors prevent userdata-based installation of httpd. A filesystem service might not be running at the time userdata scripts are executed

Expected results:
it is possible to install httpd via userdata cloud-init script


Additional info:
# screenlog
[root@ip-10-49-39-30 ~]# tail -30 /var/log/httpd_userdata.log 
Non-fatal POSTIN scriptlet failure in rpm package apr-1.4.6-6.fc19.x86_64
  Installing : apr-util-1.4.1-8.fc19.x86_64                                 2/6 
warning: %post(apr-util-1.4.1-8.fc19.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package apr-util-1.4.1-8.fc19.x86_64
  Installing : httpd-tools-2.4.6-2.fc19.x86_64                              3/6 
  Installing : mailcap-2.1.41-1.fc19.noarch                                 4/6 
  Installing : fedora-logos-19.0.4-2.fc19.noarch                            5/6 
warning: %post(fedora-logos-19.0.4-2.fc19.noarch) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package fedora-logos-19.0.4-2.fc19.noarch
error: %pre(httpd-2.4.6-2.fc19.x86_64) scriptlet failed, exit status 127
Error in PREIN scriptlet in rpm package httpd-2.4.6-2.fc19.x86_64
error: httpd-2.4.6-2.fc19.x86_64: install failed
warning: %posttrans(fedora-logos-19.0.4-2.fc19.noarch) scriptlet failed, exit status 127
Non-fatal POSTTRANS scriptlet failure in rpm package fedora-logos-19.0.4-2.fc19.noarch
  Verifying  : fedora-logos-19.0.4-2.fc19.noarch                            1/6 
  Verifying  : mailcap-2.1.41-1.fc19.noarch                                 2/6 
  Verifying  : apr-util-1.4.1-8.fc19.x86_64                                 3/6 
  Verifying  : httpd-tools-2.4.6-2.fc19.x86_64                              4/6 
  Verifying  : apr-1.4.6-6.fc19.x86_64                                      5/6 
  Verifying  : httpd-2.4.6-2.fc19.x86_64                                    6/6 

Dependency Installed:
  apr.x86_64 0:1.4.6-6.fc19               apr-util.x86_64 0:1.4.1-8.fc19       
  fedora-logos.noarch 0:19.0.4-2.fc19     httpd-tools.x86_64 0:2.4.6-2.fc19    
  mailcap.noarch 0:2.1.41-1.fc19         

Failed:
  httpd.x86_64 0:2.4.6-2.fc19                                                   

Complete!
Comment 1 Daniel Walsh 2013-09-23 09:05:02 EDT
Any avc messages

ausearch -m avc -ts recent
Comment 2 Garrett Holmstrom 2013-09-26 19:18:04 EDT
This is indeed an selinux-policy issue.  See #990910.

*** This bug has been marked as a duplicate of bug 990910 ***

Note You need to log in before you can comment on or make changes to this bug.