Bug 1010352 - Typo in systemd system definition file
Typo in systemd system definition file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: GlusterFS Bugs list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 11:11 EDT by Justin Clift
Modified: 2015-07-13 00:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:48:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2013-09-20 11:11:39 EDT
Description of problem:

  There is a minor typo in the systemd service definition file for
  Gluster, which shows up in user visible ways during boot:

    "Starting GlusterFS an clustered file-system server"

    "Started GlusterFS an clustered file-system server"

  "an" should be "a"


Version-Release number of selected component (if applicable):

  Upstream GlusterFS git master, as of Fri 20th Sept 2013.


How reproducible:

  Every time.

Steps to Reproduce:
1. Enable GlusterFS daemon using systemd
2. Reboot, watch the system startup log
3. The typo appears here during GlusterFS startup

Actual results:

  "Starting GlusterFS an clustered file-system server"

  "Started GlusterFS an clustered file-system server"


Expected results:

  "Starting GlusterFS a clustered file-system server"

  "Started GlusterFS a clustered file-system server"
Comment 1 Anand Avati 2013-09-20 11:21:33 EDT
REVIEW: http://review.gluster.org/5981 (Fix typo in systemd service definition file) posted (#1) for review on master by Justin Clift (jclift@redhat.com)
Comment 2 Anand Avati 2013-09-20 14:04:07 EDT
COMMIT: http://review.gluster.org/5981 committed in master by Anand Avati (avati@redhat.com) 
------
commit 90ec0917558e6836d98faa4406b96158b13eacee
Author: Justin Clift <jclift@redhat.com>
Date:   Fri Sep 20 16:05:28 2013 +0100

    Fix typo in systemd service definition file
    
    Change-Id: Ia9dac04ad508fbaafbed24b2137b09872a1ca53c
    BUG: 1010352
    Signed-off-by: Justin Clift <jclift@redhat.com>
    Reviewed-on: http://review.gluster.org/5981
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:48:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.