Bug 1010393 - [amqp1.0] amqp1.0 message is not routed to alternate exchange
[amqp1.0] amqp1.0 message is not routed to alternate exchange
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
medium Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Petr Matousek
:
Depends On:
Blocks: 1010399
  Show dependency treegraph
 
Reported: 2013-09-20 12:58 EDT by Petr Matousek
Modified: 2015-01-21 07:56 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:56:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5051 None None None Never

  None (edit)
Description Petr Matousek 2013-09-20 12:58:46 EDT
Description of problem:

There is a subscriber on amq.direct. Another client creates an exchange with amq.direct as alternate exchange and sends a message towards it.
Since there is no binding/subscription on the defined exchange yet the message shall be routed to the alternate exchange.

Note: Using 0-10 publisher the message is delivered to the consumer on amq.direct

Please see additional info for more details.

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-14

How reproducible:
100%

Steps to Reproduce:
1. ./drain -f --connection-options "{  protocol : 'amqp1.0' }" amq.direct
2. ./spout --connection-options "{protocol:'amqp1.0'}" "ex;{create:always,node:{type:topic,x-declare:{alternate-exchange:amq.direct}}}"
3. the message was not delivered to the consumer on amq.direct

Actual results:
Message is not delivered to alternate exchange

Expected results:
Message is delivered to alternate exchange

Additional info:

Following cases works well:

1. using amqp1.0:

Declaring the exchange using one client: 
./drain  --connection-options "{protocol:'amqp1.0'}" "ex;{create:always,node:{type:topic, x-declare:{alternate-exchange:amq.direct}}}"

Sending the message using another client (using other connection):
./spout ex

2. Defining the exchange and sending the message using 0-10 client:
./spout "ex;{create:always,node:{type:topic,x-declare:{alternate-exchange:amq.direct}}}"
Comment 1 Gordon Sim 2013-09-20 15:35:26 EDT
Fixed upstream: https://svn.apache.org/r1525090
Comment 2 Petr Matousek 2014-01-17 12:26:29 EST
This issue has been fixed. Verified on rhel6.5 (x86_64, i386).

packages under test:
qpid-cpp-*-0.22-33

-> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.