Bug 1010412 - candlepin-cert mangles repo_ca_cert parameter in rhsm.conf
candlepin-cert mangles repo_ca_cert parameter in rhsm.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Garik Khachikyan
: Triaged
Depends On: 1010404
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 13:45 EDT by Mike McCune
Modified: 2015-01-04 17:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1010404
Environment:
Last Closed: 2014-04-24 13:08:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-09-20 13:45:51 EDT
+++ This bug was initially created as a clone of Bug #1010404 +++

Description of problem:

Installing candlepin-cert to a client from a katello/headpin instances does a bad string interpollation for the repo_ca_cert parameter in rhsm.conf

should be:

  repo_ca_cert = %(ca_cert_dir)scandlepin-local.pem

instead it is

  repo_ca_cert = scandlepin-local.pem

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.26-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-11.el6sat.noarch
* katello-cli-common-1.4.3-11.el6sat.noarch
* katello-common-1.4.3-15.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-15.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-15.el6sam_splice.noarch
* katello-headpin-1.4.3-15.el6sam_splice.noarch
* katello-headpin-all-1.4.3-15.el6sam_splice.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* openldap-devel-2.4.23-32.el6_4.1.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch

How reproducible:


Steps to Reproduce:
1. Install the candlepin-cert rpm from a katello/headpin instance
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Bryan Kearney on 2013-09-20 13:35:03 EDT ---

https://github.com/Katello/katello-installer/pull/49
Comment 1 RHEL Product and Program Management 2013-09-20 14:15:21 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Bryan Kearney 2013-10-03 10:51:56 EDT
fixed in commit c31ada462834cc87813f01a8ef89e5a24934e0d8
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Fri Sep 20 13:33:26 2013 -0400

    1010404: Earlier fix introduced string replacement issue
Comment 7 Garik Khachikyan 2013-10-04 03:30:37 EDT
taking QA contact
Comment 8 Garik Khachikyan 2013-10-04 09:10:38 EDT
VERIFIED

recent version fixes that issue.

cat /etc/rhsm/rhsm.conf | grep "^repo_ca_cert"
repo_ca_cert = %(ca_cert_dir)scandlepin-local.pem

version under test:
---
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-10-16-6-191.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-19.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-all-1.4.6-19.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-17.el6sat.noarch
katello-cli-common-1.4.3-17.el6sat.noarch
katello-common-1.4.6-19.el6sat.noarch
katello-configure-1.4.5-9.el6sat.noarch
katello-configure-foreman-1.4.5-9.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-9.el6sat.noarch
katello-foreman-all-1.4.6-19.el6sat.noarch
katello-glue-candlepin-1.4.6-19.el6sat.noarch
katello-glue-elasticsearch-1.4.6-19.el6sat.noarch
katello-glue-pulp-1.4.6-19.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.17.beta.el6sat.noarch
python-pulp-bindings-2.3.0-0.17.beta.el6sat.noarch
python-pulp-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.17.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.12-9.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.5-5.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.20-3.el6sat.noarch
Comment 9 Bryan Kearney 2014-04-24 13:08:21 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.