Bug 1010434 - cups-pdf does not report failures well
cups-pdf does not report failures well
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 15:05 EDT by Dale R. Worley
Modified: 2013-10-02 02:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: cups-pdf-2.6.1-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale R. Worley 2013-09-20 15:05:38 EDT
Description of problem:

Cups-PDF can fail to write its output but will still record log messages saying that the PDF creation was successfu.

Version-Release number of selected component (if applicable):

cups-pdf-2.6.1-4.fc19.x86_64

How reproducible:

reproducible

Steps to Reproduce:
1.  Set up the problem of https://bugzilla.redhat.com/show_bug.cgi?id=1009609, viz., label the home directory recursively "unconfined_u:object_r:default_t:s0
2.  Attempt to print document to Cups-PDF

Actual results:

/var/log/cups/cupsd-pdf_log reported:

Wed Sep 18 11:57:44 2013  [STATUS] PDF creation successfully finished (worley)

Expected results:

/var/log/cups/cups-pdf_log should report that PDF creation failed.

Additional info:

In https://bugzilla.redhat.com/show_bug.cgi?id=1009609, cups-pdf was unable to create the output PDF due to incorrect selinux labeling of the user's home directory.  Nonetheless, /var/log/cups/cupsd-pdf_log reported:

Wed Sep 18 11:57:44 2013  [STATUS] PDF creation successfully finished (worley)

This message is deeply deceptive and should be changed.

A very desirable improvement would be for  cups-pdf to notify the user by e-mail when it cannot create the output PDF.  (E.g., cron already uses e-mail to notify the user about jobs.)
Comment 1 Remi Collet 2013-09-23 02:57:20 EDT
The message will be fixed in next build.

For another way to report success/error (using mail), please submit this idea to upstream.
Comment 2 Fedora Update System 2013-09-23 03:09:44 EDT
cups-pdf-2.6.1-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cups-pdf-2.6.1-7.fc19
Comment 3 Fedora Update System 2013-09-23 03:09:52 EDT
cups-pdf-2.6.1-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cups-pdf-2.6.1-7.fc20
Comment 4 Fedora Update System 2013-09-23 20:24:02 EDT
Package cups-pdf-2.6.1-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-pdf-2.6.1-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17425/cups-pdf-2.6.1-7.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-02 02:38:32 EDT
cups-pdf-2.6.1-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-10-02 02:45:11 EDT
cups-pdf-2.6.1-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.