Bug 101044 - binfmt_coff.o module missing
binfmt_coff.o module missing
Status: CLOSED DUPLICATE of bug 76567
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 15:28 EDT by Rob Riggs
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Riggs 2003-07-28 15:28:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
Regression in release of kernel.  COFF format binaries can no longer be used. 
Kernel packages are missing critical binary compatibility modules.  This seems
to be a new regression in the 2.4.20 kernel releases.

Version-Release number of selected component (if applicable):
kernel-2.4.20-19.7, kernel-smp-2.4.20-19.7

How reproducible:
Always

Steps to Reproduce:
1. Try to load the binfmt_coff module
2.
3.
    

Actual Results:  modprobe: Can't locate module binfmt_coff


Expected Results:  The module should have loaded.

Additional info:

I am unable to upgrade my kernel because I require COFF binary support.  This
causes all COFF binaries to crash on execution.
Comment 1 giulioo 2003-07-29 08:26:14 EDT
linux-abi is not supported by Red Hat anymore, it never was (officially).

If you need it, either stay with the latest Red Hat version that works for you
or compile a kernel yourself using patches you find
http://linux-abi.sourceforge.net/.

Note that if you patch the Red Hat kernel it probably won't work (I'm not
speaking of patch rejects, but about functional issues) because there are some
changes (we don't know which) that are not ok for linux-abi.

Official kernels + -ac patches + linux-abi work.


*** This bug has been marked as a duplicate of 76567 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.