Bug 1010453 - Anaconda uses btrfs when lvm is selected in text mode
Anaconda uses btrfs when lvm is selected in text mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-20 15:36 EDT by Paul Whalen
Modified: 2013-10-10 07:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-20.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 07:49:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-09-20 15:36:11 EDT
Description of problem:
When using text mode for anaconda installations the default is to use LVM, however resulting system is btrfs. 

Version-Release number of selected component (if applicable):
anaconda-20.18-1.fc20

How reproducible:
everytime

Steps to Reproduce:
1. Begin text installation of F20 Alpha RC4
2. Select disk leaving defaults (LVM)
3. Install and reboot. 


Actual results:
uses btrfs

Expected results:
uses LVM

Additional info:
This occurs on both ARM and x86 in F20 Alpha RC4
Comment 1 Paul Whalen 2013-09-24 15:42:38 EDT
Proposed Blocker:
"When using the guided partitioning flow, the installer must be able to: Complete an installation using any combination of disk configuration options it allows the user to select"
Comment 2 Andre Robatino 2013-09-24 16:27:59 EDT
Confirmed. I also checked that the last compose where this worked properly was RC1 (RC2 also used btrfs and RC3 couldn't do text install at all). I should have caught it since I always test text install and usually do a "df -T" afterwards to check the filesystems (they also appear at the beginning of installation). The above criteria is for Beta specifically, BTW, I didn't see anything under Alpha criteria.

https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Guided_partitioning
Comment 3 Fedora Update System 2013-09-25 12:03:38 EDT
anaconda-20.20-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.20-1.fc20
Comment 4 Mike Ruckman 2013-09-25 12:20:39 EDT
Discussed this in 2013-09-25 Blocker Review Meeting [1]. This was validated as an AcceptedBlocker. It violates the following F20 beta release criterion for lvm partitioning in text installs: "Complete an installation using any combination of disk configuration options it allows the user to select"

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
Comment 5 Fedora Update System 2013-09-26 20:31:40 EDT
Package anaconda-20.20-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.20-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17681/anaconda-20.20-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-09-27 21:16:38 EDT
anaconda-20.21-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.21-1.fc20
Comment 7 Andre Robatino 2013-10-05 21:08:47 EDT
Verified fixed in 20 Beta TC1 (anaconda-20.21-1). This anaconda has been pushed to stable, so if no one else sees this, the bug can be closed.
Comment 8 Adam Williamson 2013-10-10 07:49:48 EDT
Closing per above. pwhalen, please re-open if you're still seeing this as of TC2.

Note You need to log in before you can comment on or make changes to this bug.