Bug 1010454 - grubby - new-kernel-pkg - LANG
grubby - new-kernel-pkg - LANG
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
: 1060332 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 15:40 EDT by poma
Modified: 2014-09-17 05:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1060332 1098749 (view as bug list)
Environment:
Last Closed: 2014-05-17 11:58:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Thank you for everything LANG. Farewell. (427 bytes, patch)
2013-09-20 15:40 EDT, poma
no flags Details | Diff

  None (edit)
Description poma 2013-09-20 15:40:59 EDT
Created attachment 800655 [details]
Thank you for everything LANG. Farewell.

During the kernel install the 'LANG=<LOCALE>' directive is copied from the '/etc/locale.conf' and appended to the kernel parameters line in the bootloader configuration file.
As far as I'm concerned this is redundant, cause the 'systemd-localed.service' is the one responsible for the system locale settings, already.

e.g.
/etc/locale.conf:
LANG=en_US.utf8

/boot/extlinux/extlinux.conf
…
append … LANG=en_US.utf8
…
Comment 1 poma 2013-10-03 12:48:24 EDT
No news here either.
Good luck.
Comment 2 Marcos Mello 2013-11-28 06:51:33 EST
Should not Anaconda write locale.LANG (as it already does with vconsole.font and vconsole.keymap) to the bootloader configuration and your patch be applied? Or perhaps /etc/{vconsole.conf,locale.conf} and /etc/sysconfig/{keyboard,i18n} import section be removed entirely?

I configure boot options in /etc/default/grub. Get *new* ones from new-kernel-pkg is unexpected.
Comment 3 Marcos Mello 2014-01-23 07:44:31 EST
/etc/sysconfig/i18n and /etc/sysconfig/keyboard are both dead now. Thus SYSFONT, SYSFONTACM, UNIMAP, KEYTABLE, are gone too. LANG by luck is still used in /etc/locale.conf, but I am not sure it serves any purpose anymore considering dracut already put /etc/{vconsole.conf,locale.conf} in the initramfs.
Comment 4 Marcos Mello 2014-01-23 08:24:49 EST
BTW, since F20 Anaconda does not write vconsole.keymap anymore, see bug 1035316 .
Comment 6 Marcos Mello 2014-02-02 09:17:55 EST
*** Bug 1060332 has been marked as a duplicate of this bug. ***
Comment 8 poma 2014-02-05 01:17:46 EST
I see no purpose cause the maintainer doesn't respond.
However, here it is.
Good look.
Comment 9 Marcos Mello 2014-03-21 16:39:52 EDT
*** Bug 1060332 has been marked as a duplicate of this bug. ***
Comment 10 Marcos Mello 2014-03-21 16:41:14 EDT
I have marked bug 1060332 as a duplicate. Please keep this bug open.
Comment 11 Marcos Mello 2014-03-21 16:49:31 EDT
cc'ing Harald.

Harald, does LANG= do anything since

http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=6c8fc6e377b94e26e6d03cddbf174cb27caad0a6

?
Comment 12 Harald Hoyer 2014-04-04 05:47:50 EDT
(In reply to Marcos Mello from comment #11)
> cc'ing Harald.
> 
> Harald, does LANG= do anything since
> 
> http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/
> ?id=6c8fc6e377b94e26e6d03cddbf174cb27caad0a6
> 
> ?

Hmm, not really. On the kernel command line, one should use "rd.locale.LANG=" to overwrite the language in the initramfs. This might be used to use a different language, than the one which is in $initramfs/etc/locale.conf (copied from the system, the last time dracut was called to generate the initramfs) or in case of the rescue initramfs (which has no locale.conf) to set the language.

If you use "locale.LANG=", you overwrite the setting of the real root /etc/locale.conf, which you probably don't want.
Comment 13 Marcos Mello 2014-04-04 12:51:32 EDT
Thank you for the explanation. Just like
https://bugzilla.redhat.com/show_bug.cgi?id=1033250
https://bugzilla.redhat.com/show_bug.cgi?id=1074113

Therefore all /etc/sysconfig/{i18n,keyboard} and /etc/{locale.conf,vconsole.conf} import stuff may be dropped from new-kernel-pkg because default initramfs is HostOnly. There is an usecase that I think deserves be documented: when you need a generic initramfs (i.e. install dracut-config-generic) and want to keep console/locale settings in it. As you told me on IRC, a simple Dracut snippet config file does the job

/etc/dracut.conf.d/console.conf

install_items+=" /etc/vconsole.conf /etc/locale.conf "

Besides that, should we have any rd.locale.XXX in the bootloader options? I never used the rescue initramfs. For it maybe? (it would be Anaconda business anyway)
Comment 14 Marcos Mello 2014-04-25 17:41:50 EDT
It affects RHEL 7.0 RC too.
Comment 15 Marcos Mello 2014-05-17 12:12:08 EDT
Why can not you keep this bug open? I agree that nobody appears to care, but closing it will just make it harder to someone take a look into this someday.
Comment 16 poma 2014-09-17 05:51:13 EDT
Someday in the next century? :)
I take care of my reports and if there is no interest there is no need to stand open collecting dust.

Adieu.

Note You need to log in before you can comment on or make changes to this bug.