Bug 1010509 - [abrt] gnome-tweak-tool-3.9.91-1.fc20: utils.py:308:__init__:TypeError: add_action() takes exactly 5 arguments (6 given)
[abrt] gnome-tweak-tool-3.9.91-1.fc20: utils.py:308:__init__:TypeError: add_a...
Status: CLOSED DUPLICATE of bug 1009343
Product: Fedora
Classification: Fedora
Component: gnome-tweak-tool (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-09-20 19:16 EDT by Lawrenc Graves
Modified: 2013-10-13 18:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-13 18:09:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (765 bytes, text/plain)
2013-09-20 19:16 EDT, Lawrenc Graves
no flags Details
File: environ (1.42 KB, text/plain)
2013-09-20 19:16 EDT, Lawrenc Graves
no flags Details

  None (edit)
Description Lawrenc Graves 2013-09-20 19:16:39 EDT
Version-Release number of selected component:

Additional info:
reporter:       libreport-2.1.7
cmdline:        python /usr/bin/gnome-tweak-tool
executable:     /usr/bin/gnome-tweak-tool
kernel:         3.11.1-300.fc20.x86_64
runlevel:       unknown
type:           Python
uid:            1000

Truncated backtrace:
utils.py:308:__init__:TypeError: add_action() takes exactly 5 arguments (6 given)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gtweak/widgets.py", line 178, in _on_changed_notify_logout
  File "/usr/lib/python2.7/site-packages/gtweak/tweakmodel.py", line 68, in notify_logout
    self._logoutnotification = LogoutNotification()
  File "/usr/lib/python2.7/site-packages/gtweak/utils.py", line 42, in getinstance
    instances[cls] = cls()
  File "/usr/lib/python2.7/site-packages/gtweak/utils.py", line 308, in __init__
    self._logout, None, None)
TypeError: add_action() takes exactly 5 arguments (6 given)

Local variables in innermost frame:
self: <gtweak.utils.LogoutNotification instance at 0x17d88c0>
Comment 1 Lawrenc Graves 2013-09-20 19:16:42 EDT
Created attachment 800800 [details]
File: backtrace
Comment 2 Lawrenc Graves 2013-09-20 19:16:44 EDT
Created attachment 800801 [details]
File: environ
Comment 3 Mike FABIAN 2013-09-26 12:46:34 EDT
This can be reproduced on Fedora 20 Alpha with gnome-tweak-tool-3.9.92-1.fc20.noarch

- start gnome-tweak-tool
- click “Keyboard and Mouse”
- move the switch “Show all Input Sources” (in either direction)
Comment 4 Barry Fishman 2013-10-10 09:41:33 EDT
This seems to be the same as bug 1015900 I filed for mailnag.

There seems to be an unconfirmed API change to Notify.Notification().add_action(...) removing its last argument.

If this is true, multiple applications would be effected,
Comment 5 Mohamed El Morabity 2013-10-13 18:09:11 EDT

*** This bug has been marked as a duplicate of bug 1009343 ***

Note You need to log in before you can comment on or make changes to this bug.