Bug 1010531 - vmusr[1334]: [ warning] [GLib-GObject]
vmusr[1334]: [ warning] [GLib-GObject]
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: open-vm-tools (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravindra Kumar
Fedora Extras Quality Assurance
:
: 1067150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 05:17 EDT by orti1980
Modified: 2015-11-16 17:00 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 17:00:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description orti1980 2013-09-21 05:17:34 EDT
Sep 21 11:01:08 localhost vmusr[1334]: [ warning] [GLib-GObject] Attempt to add property ToolsCoreService::tcs-app-ctx after class was initialised
Sep 21 11:01:08 localhost vmusr[1334]: [ warning] [GLib-GObject] Attempt to add property ToolsCoreService::tcs-prop-thread-pool after class was initialised
Sep 21 11:01:08 localhost vmusr[1334]: [ warning] [vmtoolsd] The vmusr service needs to run inside a virtual machine.
Comment 1 Ravindra Kumar 2014-11-05 22:13:49 EST
*** Bug 1067150 has been marked as a duplicate of this bug. ***
Comment 2 Jaroslav Reznik 2015-03-03 10:05:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 3 Sitsofe Wheeler 2015-06-08 04:15:30 EDT
I no longer see the GLib-GObject warnings in Fedora 22 - resolve as fixed?
Comment 4 Ravindra Kumar 2015-11-16 17:00:41 EST
(In reply to Sitsofe Wheeler from comment #3)
> I no longer see the GLib-GObject warnings in Fedora 22 - resolve as fixed?

Thanks Sitsofe! Yes.

I did some more research on the glib change in g_object_class_install_property() API and found the glib bug which added this warning and later removed it.

Link to gnome bug, https://bugzilla.gnome.org/show_bug.cgi?id=698614

There was a code change made in gobject 2.38 to add the warning to g_object_class_install_property() API. This was later reverted and converted to a documentation warning in gobject 2.42. So, you would see this warning only if you are using the affected gobject library versions i.e. 2.38 or 2.40.

The warning in using g_object_class_install_property() after class initialization is about thread safety. open-vm-tools has been using this feature of gobject since ages and it is not multi-threaded during initialization when g_object_class_install_property() API is called. So, there is nothing to be fixed.

Note You need to log in before you can comment on or make changes to this bug.