Bug 1010617 - libvirt leak vm on failure to qemu-attach a process
libvirt leak vm on failure to qemu-attach a process
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
:
Depends On: 995312
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 23:34 EDT by Hao Liu
Modified: 2014-06-17 20:56 EDT (History)
9 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 995312
Environment:
Last Closed: 2014-06-13 06:29:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hao Liu 2013-09-21 23:34:08 EDT
+++ This bug was initially created as a clone of Bug #995312 +++

Description of problem:
libvirt leak vm on failure to qemu-attach a process
 
Version-Release number of selected component (if applicable):
libvirt-1.1.1-6.el7.x86_64

How reproducible:
100%

Steps:
1. Create guest image and start guest from qemu-kvm command.
# qemu-img create /var/lib/libvirt/images/foo.img 1G
Formatting '/var/lib/libvirt/images/foo.img', fmt=raw size=1073741824

# /usr/libexec/qemu-kvm -cdrom /var/lib/libvirt/images/foo.img -monitor unix:/tmp/demo,server,nowait -name foo -uuid cece4f9f-dff0-575d-0e8e-01fe380f12ea  &
[1] 13155
VNC server running on `::1:5900'

2.Attach qemu-kvm process to libvirtd.
# virsh qemu-attach 13155
error: An error occurred, but the cause is unknown

3.Check VM leak.
$ virsh list --all
 Id    Name                           State
----------------------------------------------------
 2     foo                            shut off

$ virsh shutdown foo
error: Failed to shutdown domain foo
error: invalid argument: monitor must not be NULL
Comment 3 Eric Blake 2013-09-23 11:22:44 EDT
Correct - there are patches since 1.1.1 was released that need to be backported to RHEL 7.  I'm working on it now.
Comment 6 Hao Liu 2013-09-26 02:01:57 EDT
VERIFIED this patch.

Verifying Package:
libvirt-1.1.1-6.el7.x86_64

Verifying Steps:
Following the steps in [1], when running:
$ virsh list --all
 Id    Name                           State
----------------------------------------------------

VM no longer leaks, so this patch is VERIFIED.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1010617#c0
Comment 7 Ludek Smid 2014-06-13 06:29:31 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.