Bug 1010635 - btrfs-convert: No valid Btrfs found
btrfs-convert: No valid Btrfs found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 03:54 EDT by Rolf Fokkens
Modified: 2013-12-09 21:40 EST (History)
4 users (show)

See Also:
Fixed In Version: btrfs-progs-3.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 21:40:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2013-09-22 03:54:21 EDT
Description of problem:
When trying to convert an ext4 FS to BTRFS btrfs-convert refuses claiming "No valid Btrfs found in /dev/mapper/BCACHE-ROOTFS'


Version-Release number of selected component (if applicable):
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc20.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Build a system running root on LVM
2. Boot an F20 Live DVD
3. yum install btrfs-progs
4. start btrfs-convert /dev/mapper/BCACHE-ROOTFS
5. Error: No valid Btrfs found on /dev/mapper/BCACHE-ROOTFS

Actual results:
No valid Btrfs found on /dev/mapper/BCACHE-ROOTFS
unable to open ctree
conversion aborted.


Expected results:
Smooth conversion

Additional info:
http://thread.gmane.org/gmane.comp.file-systems.btrfs/28290
Comment 1 Rolf Fokkens 2013-09-22 04:05:32 EDT
The more simple case provide by "Additional info" can also be used to reproduce:

Quote:
  way to reproduce error:
  $ truncate -s 4G file
  $ mkfs.ext4 file #say yes to create fs on non block device.
  $ btrfs-convert file
   No valid Btrfs found on file
   unable to open ctree
   conversion aborted.
Comment 2 Eric Sandeen 2013-09-23 14:47:43 EDT
Yep, this was regression reported upstream some time ago.  A patch to fix it has been sent to the list, but a month later upstream still hasn't merged it (or any other patches).

When upstream accepts the fix, we can update btrfs-progs in Fedora to fix this bug.

thanks,
-Eric
Comment 3 Tim Landscheidt 2013-10-02 13:42:58 EDT
JFTR: This is also present in Fedora 19 and needs to be fixed there as well.
Comment 4 Eric Sandeen 2013-10-04 13:34:41 EDT
And still JFTR: If upstream ever accepts this (or for that matter any) patch, I'll gladly fix it.

"Upstream first" - live by the sword, die by the sword.  ;)

Thanks,
-Eric
Comment 5 Tim Landscheidt 2013-12-09 20:09:27 EST
With btrfs-progs-3.12-1.fc19.i686, this works for me now in Fedora 19.
Comment 6 Eric Sandeen 2013-12-09 21:40:06 EST
Great, thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.