Bug 1010649 - Bluetooth mouse is not connecting after suspending
Bluetooth mouse is not connecting after suspending
Status: CLOSED DUPLICATE of bug 988481
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Don Zickus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 05:19 EDT by RudraB
Modified: 2013-09-28 09:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 09:43:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RudraB 2013-09-22 05:19:08 EDT
Description of problem:
When enabling my laptop from suspension, my bluetooth is no pore working. A reboot is needed.

Version-Release number of selected component (if applicable):
bluez-4.101-9.fc19.x86_64
kernel-3.11.1-200.fc19.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. suspend the machine
2. re-enable the machine
3. try to work with the mouse

Actual results:
Not working

Expected results:
should work 

Additional info:
Comment 1 RudraB 2013-09-22 05:21:40 EDT
$ systemctl status bluetooth.target 
bluetooth.target - Bluetooth
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.target; static)
   Active: active since Sun 2013-09-22 10:05:05 BST; 16min ago
     Docs: man:systemd.special(7)

Sep 22 10:05:05 localhost.localdomain systemd[1]: Starting Bluetooth.
Sep 22 10:05:05 localhost.localdomain systemd[1]: Reached target Bluetooth.


$ systemctl status bluetooth.service 
bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Sun 2013-09-22 10:13:29 BST; 7min ago
 Main PID: 12612 (bluetoothd)
   CGroup: name=systemd:/system/bluetooth.service
           └─12612 /usr/sbin/bluetoothd -n

Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: bluetoothd[12612]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: bluetoothd[12612]: Bluetooth Management interface initialized
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: Bluetooth Management interface initialized
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: bluetoothd[12612]: Parsing /etc/bluetooth/serial.conf failed: No such file or directory
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: bluetoothd[12612]: Adapter /org/bluez/12612/hci0 has been enabled
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: bluetoothd[12612]: Unknown command complete for opcode 19
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: Adapter /org/bluez/12612/hci0 has been enabled
Sep 22 10:13:29 localhost.localdomain bluetoothd[12612]: Unknown command complete for opcode 19
Comment 2 Dimitris 2013-09-26 13:28:22 EDT
Not exactly an elegant workaround, but:

- Bluetooth on.
- Start GNOME 3 add bluetooth device dialog.
- Make mouse discoverable.
- Select mouse in the GNOME dialog.
- Select "PIN options", "0000" option.
- Mouse pairs and connects.
- Suspend laptop.
- Resume laptop.
- Turn bluetooth off.
- Turn bluetooth on.
- Mouse reconnects.

Explicitly selecting the "0000" PIN option is necessary, otherwise the pairing is "forgotten" - device shows up but "not paired" in the GNOME dialog.

Bouncing bluetooth after resume is also necessary, otherwise even though paired the mouse doesn't reconnect after resume.
Comment 3 Berend De Schouwer 2013-09-27 04:08:25 EDT
I've got the same (or similar)

I can reconnect without bouncing bluetooth, but I have to enable/disable bluetooth multiple times, and hit the 'connect' button on the mouse multiple times.

Started a few days ago.  Possibly related from yum.log:

Aug 01 09:51:50 Updated: bluez-4.101-9.fc19.x86_64
Sep 19 10:34:07 Installed: kernel-3.11.1-200.fc19.x86_64

I don't think it was a problem in August.
Comment 4 Hans de Goede 2013-09-28 09:43:42 EDT
Hi Berend,

I just hit the same problem, and I've managed to fix it for my case (Dell E6430 laptop with integrated bluetooth). As such I believe this bug is a duplicate of bug 988481, so lets discuss this further there.

Regards,

Hans

*** This bug has been marked as a duplicate of bug 988481 ***

Note You need to log in before you can comment on or make changes to this bug.