Bug 1010663 - override mtu field allows only values up to 9000
override mtu field allows only values up to 9000
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Lior Vernia
Martin Pavlik
network
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 06:44 EDT by Markus Stockhausen
Modified: 2015-05-04 21:44 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:27:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 23431 None None None Never
oVirt gerrit 23561 None None None Never

  None (edit)
Description Markus Stockhausen 2013-09-22 06:44:02 EDT
Description of problem:

Using IPoIB in connected mode allows MTU of 65520. Web admin interface allows only MTU of 9000 or less.


Version-Release number of selected component (if applicable):

Ovirt 3.3.0-4


How reproducible:

100%


Steps to Reproduce:
1. create new network
2. enable override mtu flag
3. enter values beyond 9000
4. try to save

Actual results:

mtu field gets a red frame (showing values are not accepted)


Expected results:

values of up to IPoIB connected mode 65520 bytes should be allowed.
Comment 1 Lior Vernia 2014-01-20 06:45:51 EST
The maximum value is now taken from the engine config value 'MaxMTU'; if it is absent, then the default will remain 9000.
Comment 2 Andrew Cathrow 2014-01-20 11:43:27 EST
Lior, is this config accessible in the engine-config tool?
Comment 3 Lior Vernia 2014-01-21 03:12:12 EST
Andrew, I thought it was but it isn't, so effectively this isn't exposed to users. Discussed and gonna lift the MTU limit altogether.
Comment 4 Lior Vernia 2014-01-22 08:23:36 EST
Over-automation.
Comment 5 Sandro Bonazzola 2014-02-07 06:20:10 EST
Fixes should be in ovirt-3.4.0-beta2. Assignee please check.
Comment 6 Martin Pavlik 2014-02-12 03:47:37 EST
verified with
oVirt Engine Version: 3.4.0-0.7.beta2.el6
vdsm-4.14.1-3.el6.x86_64

MTU 66000 was set in engine, host which was not capable of such MTU was correctly marked as network not synchronized

Host dell-05's following network(s) are not synchronized with their Logical Network configuration: huge_MTU.
Comment 7 Sandro Bonazzola 2014-03-31 08:27:48 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.