Bug 1010676 - [event notification][upgrade] upgrade won't keep event-notifier configuration.
[event notification][upgrade] upgrade won't keep event-notifier configuration.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Alex Lourie
Tareq Alayan
integration
: Triaged
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-09-22 08:39 EDT by Tareq Alayan
Modified: 2013-11-10 07:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-27 11:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (150.74 KB, application/x-gzip)
2013-09-22 08:42 EDT, Tareq Alayan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20461 None None None Never

  None (edit)
Description Tareq Alayan 2013-09-22 08:39:42 EDT
Description of problem:
After rhevm-setup to a newer build the old confguration related to event-notifier are lost.

Version-Release number of selected component (if applicable):
is15

How reproducible:
always

Steps to Reproduce:
1. have is14 installed/ event-notifier running and mail server is confgured
2. modify repos to have is15 
3. rhevm-setup to upgarde to is15
4. service ovirt-engine-notifier start

Actual results:
the service will stop because the mail server is not confgured

Expected results:
run as expected

Additional info:
Comment 1 Tareq Alayan 2013-09-22 08:42:27 EDT
Created attachment 801185 [details]
logs
Comment 2 Alon Bar-Lev 2013-10-03 03:57:08 EDT
As the change in notifier configuration and service was significant, the upgrade does not try to update its configuration.

I am not sure that it is worth the effort to automatically convert the configuration for this component and not just ask user to reconfigure it, but all seem to think that it is.
Comment 4 Alex Lourie 2013-10-24 01:52:36 EDT
Tareq

I've ran similar flow on my system, and it worked correctly.

Could you please try to recreate the issue and:

1. Tell me how do you configure notifier's mail.
2. Attach the /etc/ovirt-engine/notifier/notifier.conf file prior to upgrade
3. Attach the /etc/ovirt-engine/notifier contents after the upgrade.

Thanks.
Comment 5 Tareq Alayan 2013-10-27 10:48:49 EDT
couldn't reproduce this issue with rhevm-3.3.0-0.28.beta1.el6ev.noarch
Comment 6 Alon Bar-Lev 2013-10-27 11:25:18 EDT
Marking this as notabug, nothign was changed since is15 as far as I know.

Note You need to log in before you can comment on or make changes to this bug.