Bug 1010691 - all-in-one: do not perform all in one installation if there are no cpu capabilities
all-in-one: do not perform all in one installation if there are no cpu capabi...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.3
Unspecified Unspecified
medium Severity unspecified
: ---
: 3.3.2
Assigned To: Alex Lourie
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 11:06 EDT by Ohad Basan
Modified: 2013-12-19 09:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:24:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19540 None None None Never
oVirt gerrit 20385 None None None Never
oVirt gerrit 20541 None None None Never

  None (edit)
Description Ohad Basan 2013-09-22 11:06:29 EDT
Description of problem:
Currently there is a failure in the validation flow,
meaning, the all-in-one plugin is running (creating a dc and trying to create a cluster)
even if cpu capabilities are missing from the machine.
Comment 1 Itamar Heim 2013-09-23 17:21:20 EDT
ohad - is this with fedora 19? you need latest fedora qemu/libvirt for this to work.
I don't think its worth handling this use case otherwise (unless i'm missing something)
Comment 2 Ohad Basan 2013-09-24 03:32:36 EDT
actually it happened to me on a centos 6.4 machine.
Comment 3 Itamar Heim 2013-09-24 06:54:39 EDT
how come there are not cpu capabilities?
Comment 4 Ohad Basan 2013-09-24 07:41:26 EDT
because I accidently ran the setup on a vm
obviously it can't run all in one
but the setup should notify me and quit when this happens.
Comment 5 Sandro Bonazzola 2013-09-24 11:00:26 EDT
(In reply to Ohad Basan from comment #4)
> because I accidently ran the setup on a vm
> obviously it can't run all in one
> but the setup should notify me and quit when this happens.

I think that if nested VM is working (vdsm-hook-nestedvt), you should be able to install AIO also inside a VM (nested VM doesn't work on my laptop with emulated CPU westmere).
It just seems that the all-in-one/cpu plugin doesn't detect correctly the VM's cpu.
Comment 6 Alex Lourie 2013-09-24 11:25:29 EDT
Ohad

Please reproduce and attach logs of the failure.

Also, if you could change the code to pring that cpu value, that would be great too. Use something like

self.logger.debug('The value of cpu is \'{cpu}\''.format(cpu=cpu))

Thanks.
Comment 7 Sandro Bonazzola 2013-10-21 09:24:13 EDT
Still missing the backport to 3.3 branch
Comment 8 Sandro Bonazzola 2013-11-07 03:59:38 EST
Targeting to 3.3.2 sincce it's not in 3.3.1 branch.
Comment 9 Sandro Bonazzola 2013-12-13 11:02:10 EST
rc build done, moving to ON_QA, packages will be available on updates-testing repository.
Comment 10 Sandro Bonazzola 2013-12-19 09:24:48 EST
oVirt 3.3.2 has been released resolving the problem described in this bug report.

Note You need to log in before you can comment on or make changes to this bug.