Bug 1010706 - [PATCH] Work with GPG signed git commits
[PATCH] Work with GPG signed git commits
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: GitPython (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: EasyFix, Patch
: 1037922 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 13:06 EDT by Igor Gnatenko
Modified: 2013-12-30 00:05 EST (History)
3 users (show)

See Also:
Fixed In Version: GitPython-0.3.2-0.6.RC1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 14:07:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for master branch (4.99 KB, patch)
2013-09-22 13:06 EDT, Igor Gnatenko
no flags Details | Diff
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch (5.05 KB, patch)
2013-09-28 14:39 EDT, Igor Gnatenko
no flags Details | Diff
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch (5.03 KB, patch)
2013-09-28 14:45 EDT, Igor Gnatenko
no flags Details | Diff
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch (10.20 KB, patch)
2013-10-07 02:59 EDT, Igor Gnatenko
no flags Details | Diff

  None (edit)
Description Igor Gnatenko 2013-09-22 13:06:24 EDT
Created attachment 801249 [details]
Proposed patch for master branch

I want to add patch[0] as downstream..

$ ../kernel-package/kernel-package.py 
Traceback (most recent call last):
  File "../kernel-package/kernel-package.py", line 338, in <module>
    main()
  File "../kernel-package/kernel-package.py", line 326, in main
    options = Options(WORK_DIR)
  File "../kernel-package/kernel-package.py", line 60, in __init__
    self.author = self.hcommit.author
  File "/usr/lib64/python2.7/site-packages/gitdb/util.py", line 238, in __getattr__
    self._set_cache_(attr)
  File "/usr/lib/python2.7/site-packages/git/objects/commit.py", line 132, in _set_cache_
    self._deserialize(StringIO(stream.read()))
  File "/usr/lib/python2.7/site-packages/git/objects/commit.py", line 443, in _deserialize
    self.author.name = self.author.name.decode(self.encoding) 
LookupError: unknown encoding: object a0f6ed8ebe4f6d494ef70f67d4c0c153cbf59577


[0]https://github.com/gitpython-developers/GitPython/pull/57
Comment 1 Igor Gnatenko 2013-09-28 14:39:00 EDT
Created attachment 804474 [details]
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch

Updated patch
Comment 2 Igor Gnatenko 2013-09-28 14:45:29 EDT
Created attachment 804475 [details]
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch
Comment 3 Igor Gnatenko 2013-10-07 02:59:48 EDT
Created attachment 808732 [details]
0001-Fix-crashing-w-LookupError-unknown-encoding-object-a.patch

Updated fix w/ tests
Comment 5 Igor Gnatenko 2013-12-04 00:26:34 EST
*** Bug 1037922 has been marked as a duplicate of this bug. ***
Comment 6 Ankur Sinha (FranciscoD) 2013-12-04 04:17:53 EST
Igor, can you make the summary more descriptive so the maintainer will know what it's about? It isn't very clear what the issue here is too. Is this about it not taking gpg signed commits, since you closed that bug as a dup?
Comment 7 Igor Gnatenko 2013-12-04 07:55:45 EST
Sure ;)
Comment 8 Fedora Update System 2013-12-07 16:58:21 EST
GitPython-0.3.2-0.6.RC1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/GitPython-0.3.2-0.6.RC1.el6
Comment 9 Fedora Update System 2013-12-07 16:59:35 EST
GitPython-0.3.2-0.6.RC1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/GitPython-0.3.2-0.6.RC1.fc19
Comment 10 Fedora Update System 2013-12-07 17:00:23 EST
GitPython-0.3.2-0.6.RC1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/GitPython-0.3.2-0.6.RC1.fc20
Comment 11 Fedora Update System 2013-12-07 17:06:22 EST
GitPython-0.3.2-0.6.RC1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/GitPython-0.3.2-0.6.RC1.fc18
Comment 12 Fedora Update System 2013-12-08 12:49:38 EST
Package GitPython-0.3.2-0.6.RC1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GitPython-0.3.2-0.6.RC1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22972/GitPython-0.3.2-0.6.RC1.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-12-17 14:07:01 EST
GitPython-0.3.2-0.6.RC1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-12-29 14:02:27 EST
GitPython-0.3.2-0.6.RC1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-12-30 00:01:21 EST
GitPython-0.3.2-0.6.RC1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-12-30 00:05:26 EST
GitPython-0.3.2-0.6.RC1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.