Bug 101074 - usb scanner not configured for system (RFE)
usb scanner not configured for system (RFE)
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 17:57 EDT by Elton Woo
Modified: 2014-03-16 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 21:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-07-28 17:57:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
start xsane, and error message pops up claiming that no scanner
can be found.

/etc/sane.d/epson must be modified from this default:
[The last two lines are Identical*. Why?]

# epson.conf
#
# here are some examples for how to configure the EPSON backend
#
# SCSI scanner:
scsi EPSON
#
# Parallel port scanner:
#pio 0x278
#pio 0x378
#pio 0x3BC
#
# USB scanner - only enable this if you have an EPSON scanner. It could
#               otherwise block your non-EPSON scanner from being 
#               recognized.
#		Depending on your distribution, you may need either the
#		first or the second entry.
#usb /dev/usb/scanner0
#usb /dev/usb/scanner0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start xsane or kscan
2. system complains that no scanner can be found.
3.
    

Actual Results:  unable to run scanner. Must be manually configured by changing
entries in /etc/sane.d/*.conf file.

Expected Results:  scan program should load and find scanner, since USBview and 
hardware device can *both* correctly detect and identify the 
attached flatbed scanner.

Additional info:

Have requested this in previous betas of RH distros.
Other distros alreay have this enabled in previous versions.
Comment 1 Bill Nottingham 2005-04-26 21:41:47 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Note You need to log in before you can comment on or make changes to this bug.