Bug 1010750 - PHP system() function breaks working scripts
PHP system() function breaks working scripts
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 21:22 EDT by Chuck Forsberg
Modified: 2014-10-13 10:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-05 12:07:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Forsberg 2013-09-22 21:22:00 EDT
Description of problem:
The following script no longer
generates the vlf6.plt file as it used to.  The ds5 program works
properly when invoked from the shell.

<?php
     $command = "ds5 +2000 -0.25 1 2 3 4 5 6 7 8  >/u/h/vlf6.plt 
2>/dev/null";
     system($command);
     $command ="cd /u/h;  tek2gif vlf6.plt 2>/dev/null";
     system($command);
?>

Version-Release number of selected component (if applicable):


How reproducible:

run this script or something similar using redirection
Steps to Reproduce:
1.
2.
3.

Actual results:
nothing seems to happen anymore

Expected results:
programs executed, files generated/updated

Additional info:
Comment 1 Remi Collet 2013-09-23 01:04:43 EDT
Cannot reproduce from command line.

If SELinux is enabled, check context of /u/h
Comment 2 Remi Collet 2014-03-05 12:07:02 EST
No news, so closing.
Comment 3 Chuck Forsberg 2014-10-13 10:46:05 EDT
Problem has gone away in current vsn

Note You need to log in before you can comment on or make changes to this bug.