Bug 1010751 - mod_nss sni incompatibility with apache24
mod_nss sni incompatibility with apache24
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Harmsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1011652
  Show dependency treegraph
 
Reported: 2013-09-22 21:23 EDT by William Brown
Modified: 2016-01-08 15:55 EST (History)
8 users (show)

See Also:
Fixed In Version: mod_nss-1.0.12-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1011652 (view as bug list)
Environment:
Last Closed: 2016-01-08 15:55:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Brown 2013-09-22 21:23:22 EDT
Description of problem:

mod_nss appears to still lack support for SNI according to: https://bugzilla.mozilla.org/show_bug.cgi?id=360421

However, apache 24 states: https://httpd.apache.org/docs/2.4/upgrading.html

"""
The NameVirtualHost directive no longer has any effect, other than to emit a warning. Any address/port combination appearing in multiple virtual hosts is implicitly treated as a name-based virtual host. 
"""

This leaves mod_nss users open to issues due to the lack of SNI in nss server support.

1) Is this incorrect and mod_nss supports sni?

2) Is there a timeframe for completion if this is not the case?

3) Should this constitute a bug that mod_nss is incompatible with apache24?
Comment 1 Matthew Harmsen 2013-09-24 12:36:39 EDT
Since NSS has support for SNI, this bug will be scheduled to be addressed in Fedora 21.
Comment 2 William Brown 2014-04-09 21:40:01 EDT
Has there been any progress on this?
Comment 3 Rob Crittenden 2014-04-09 22:39:31 EDT
No, we are still waiting on support in NSS. The NSS development team is aware of the need but hasn't provided a timeline for support.
Comment 4 Jaroslav Reznik 2015-03-03 10:05:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 5 Brian J. Murrell 2015-09-11 09:15:14 EDT
Still no progress on this?  :-(
Comment 6 Rob Crittenden 2015-09-11 09:41:58 EDT
A patch has been contributed, it is under review. No ETA.
Comment 7 Fedora Update System 2015-10-02 18:10:43 EDT
mod_nss-1.0.12-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c76c1c84cf
Comment 8 Fedora Update System 2015-10-03 21:51:15 EDT
mod_nss-1.0.12-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mod_nss'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c76c1c84cf
Comment 9 Fedora Update System 2016-01-08 15:55:07 EST
mod_nss-1.0.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.