Bug 1010763 - "End" key doesn't work when messages are grouped by threads
"End" key doesn't work when messages are grouped by threads
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 22:33 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-09-24 10:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 09:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screencast showing end key bug (1.70 MB, video/webm)
2013-09-24 01:01 EDT, Ankur Sinha (FranciscoD)
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 708682 None None None Never

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-09-22 22:33:02 EDT
Description of problem:
When my messages are grouped by threads, and the threads are closed, I cannot use the end key to get to the latest message thread. It works just fine if I expand all my threads. This is sort of a regression. I'm quite sure I could use the end key to get the the latest message irrespective of whether my threads were open or closed in F19.

Version-Release number of selected component (if applicable):
[asinha@ankur  ~]$ rpm -qa \*evolution\*
evolution-3.9.92-1.fc20.x86_64
evolution-data-server-3.9.92-1.fc20.x86_64
evolution-ews-3.9.92-1.fc20.x86_64
[asinha@ankur  ~]$

How reproducible:
Always

Steps to Reproduce:
1.Collapse threads
2.Hit "end" key to go to latest message/thread
3.

Actual results:
Nothing happens. No movement at all.

Expected results:
Should go to latest thread, or lowest in the view depending on how it's sorted.

Additional info:
A one key "go to latest message/thread" is really handy :)
Comment 1 Milan Crha 2013-09-23 06:50:56 EDT
Thanks for a bug report. I tried to reproduce this, the behaviour from f19, but no luck for me, the End key does nothing but moving to the last shown row in the list. The closest I can get to your behaviour is to use End to get to the last shown row, and if it's collapsed thread node, then press Shift+ArrowRight to expand the thread and then use End key again. I tried other key combinations from 'Message->Go To' menu, but none expanded the thread on its own, even if the last message was unread.
Comment 2 Ankur Sinha (FranciscoD) 2013-09-23 10:29:36 EDT
(In reply to Milan Crha from comment #1)
> Thanks for a bug report. I tried to reproduce this, the behaviour from f19,
> but no luck for me, the End key does nothing but moving to the last shown
> row in the list. The closest I can get to your behaviour is to use End to
> get to the last shown row, and if it's collapsed thread node, then press
> Shift+ArrowRight to expand the thread and then use End key again. I tried
> other key combinations from 'Message->Go To' menu, but none expanded the
> thread on its own, even if the last message was unread.

In my F20 system here, the end key does not go to the last row (either last shown or last in the folder) if the threads are collapsed. The thread isn't supposed to be expanded on it's own. The bug is that the end key doesn't do *anything* when threads are collapsed.

Thanks,
Ankur
Comment 3 Ankur Sinha (FranciscoD) 2013-09-24 01:01:51 EDT
Created attachment 802043 [details]
Screencast showing end key bug

The screen cast shows:

- when the threads are all expanded, the end key takes me to the bottom of the list.

- when the threads are collapsed (even if some of them are collapsed), the end key causes it to "retrieve message (null)". 

These retrievals never end. They're just stuck. Cancelling them doesn't work. One must kill evolution to quit. 

Thanks,
Ankur
Comment 4 Milan Crha 2013-09-24 09:29:22 EDT
Aah, right. I wasn't able to reproduce this yesterday, thus I installed F20 and there I can reproduce this. Interestingly, I can reproduce it on git master under F19 too, where I wasn't able to yesterday. I'm moving this upstream, please
see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=708682
Comment 5 Ankur Sinha (FranciscoD) 2013-09-24 10:26:40 EDT
Thanks Milan,

Since I use the same /home directory between installs, I wasn't sure if some settings from my F19 evolution data was causing this. I would've filed a bug directly with upstream, but I wanted at least one other person to confirm it before I did. 

I'll follow it upstream. 

Thanks,
Warm regards,
Ankur

Note You need to log in before you can comment on or make changes to this bug.